Closed Bug 955342 Opened 7 years ago Closed 7 years ago

Keep the 50 debug log messages just before a disconnection with an error, even after the account is reconnected

Categories

(Chat Core :: Debug, defect)

x86
Other
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: florian, Assigned: florian)

Details

Attachments

(1 file)

*** Original post on bio 1906 at 2013-03-23 00:47:00 UTC ***

*** Due to BzAPI limitations, the initial description is in comment 1 ***
Attached patch Patch v1Splinter Review
*** Original post on bio 1906 as attmnt 2297 at 2013-03-23 00:47:00 UTC ***

This is needed for example to have debug logs of spurious I/O errors on IRC.
Attachment #8354062 - Flags: review?(clokep)
Comment on attachment 8354062 [details] [diff] [review]
Patch v1

*** Original change on bio 1906 attmnt 2297 at 2013-03-24 14:33:00 UTC ***

This looks good and seems to work as expected, it would be really nice to have some viewer that supports styling for this data, however.
Attachment #8354062 - Flags: review?(clokep) → review+
*** Original post on bio 1906 at 2013-03-24 17:47:07 UTC ***

http://hg.instantbird.org/instantbird/rev/4f0d30a29387
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.4
*** Original post on bio 1906 by qlum <qlumreg AT gmail.com> at 2013-04-26 16:09:26 UTC ***

I want to add some stuff here about what happens, maybe those details would be of use.

Firstly not all nets disconnect at the same frequency regardless of activity. I am currently connected to 
irc.quakenet.org, irc.tweakers.net, irc.stormbit.org, irc.mibbit.net, irc.ps3sanctuary.co.uk, and irc.mozilla.org

Here are some things I noticed about them

firstly Quakenet disconnects the most often, I have seen disconnects 30 minutes apart and even 2 minutes after the last message I recieved. In addition to that it also still keeps my nick in the server the moment I disconnect. Here is also another log from quakenet: http://pastebin.instantbird.com/183157

irc.mozilla.org hardly ever seems to disconnect even if its just as idle or even more idle then the other nets. also a log of that one for good measure: http://pastebin.instantbird.com/183168

the other nets disconnect at the frequency posted above. 

I see it being moved to resolved fixed, I don't know if its in the latest nightly but if it is the issue is still there for me.
*** Original post on bio 1906 by qlum <qlumreg AT gmail.com> at 2013-04-26 16:11:21 UTC ***

oops wrong bug post, derp
You need to log in before you can comment on or make changes to this bug.