a:visited is ignored, visited links stay the unvisited color

NEW
Unassigned

Status

--
minor
5 years ago
5 years ago

People

(Reporter: bugzilla, Unassigned)

Tracking

trunk
x86
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
*** Original post on bio 1914 by Billy <spanktastic2120 AT hotmail.com> at 2013-04-01 06:24:00 UTC ***

version 1.4a1pre (20130331041723)

I have added a:visited colors to both userchrome.css and the main.css of the message style im using. Visited links remain the unvisited color. In DOM Inspector it shows clicked links as having :link rules applied, so i think they are not being marked as visited after clicking. 

Here is the specific code i added.

/* link coloring */
a:link		 {color:#7F7F7F !important;}
a:visited	 {color:#000000 !important;}
a:hover		 {color:#000000 !important;}
a:active	 {color:#000000 !important;} 

The :link, :hover, and :active colors are all used properly, just not visited.

I tested it in safe-mode and it exhibited the same behavior, but that would depend heavily on whether or not the default configuration has anything specified for a:visited. 

It does this in AIM and Yahoo, i cannot attest to other protocols because i dont use other ones.
Created attachment 8354084 [details] [diff] [review]
Patch

*** Original post on bio 1914 as attmnt 2318 at 2013-04-03 11:27:00 UTC ***

I haven't tested this, but clokep said on IRC that it works.
*** Original post on bio 1914 at 2013-04-03 11:48:59 UTC ***

I briefly tested this and it seemed to work, I didn't check if it stayed between sessions, etc.

Confirming this bug.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 7 → All
Hardware: x86 → All
(Reporter)

Comment 3

5 years ago
*** Original post on bio 1914 by spanktastic2120 AT hotmail.com at 2013-04-15 01:16:16 UTC ***

Im not familiar with how this works, when does the patch get added to the nightly?
OS: All → Windows 7
Hardware: All → x86
*** Original post on bio 1914 at 2013-04-15 01:23:54 UTC ***

(In reply to comment #3)
> Im not familiar with how this works, when does the patch get added to the
> nightly?

It first has to be reviewed, this has not passed review yet.  We have a few questions about this that would need to be solved:
- What are the privacy implications? Currently we don't keep any history so we don't need to give users a way to clear the history. If we kept history for only the current session we wouldn't necessarily need to care about this.
- How would this affect Thunderbird? Thunderbird does not currently keep history at all.

Once the patch passes review (you'd get emails for that) then the patch will be checked-in for the next nightly and we'll post a link to hg.instantbird.org that shows the changeset and mark the bug as "RESOLVED FIXED".

Hopefully we can get a chance to look at this soon!
You need to log in before you can comment on or make changes to this bug.