Closed Bug 955376 Opened 8 years ago Closed 8 years ago

Accounts are reconnected during shutdown

Categories

(Chat Core :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: florian, Assigned: florian)

References

Details

(Whiteboard: [1.4-blocking][regression])

Attachments

(1 file)

*** Original post on bio 1938 at 2013-04-18 21:53:00 UTC ***

*** Due to BzAPI limitations, the initial description is in comment 1 ***
Blocks: 955279
Attached patch PatchSplinter Review
*** Original post on bio 1938 as attmnt 2386 at 2013-04-18 21:53:00 UTC ***

While debugging bug 955365 (bio 1928), I've noticed that shutdown isn't clean at all these days (several JS errors). It turns out the cause is attempting to connect accounts just after disconnecting them during shutdown.

This seems a regression caused by bug 955279 (bio 1846).
Attachment #8354153 - Flags: review?(aleth)
Whiteboard: [1.4-blocking][regression]
Comment on attachment 8354153 [details] [diff] [review]
Patch

*** Original change on bio 1938 attmnt 2386 at 2013-04-18 23:47:13 UTC was without comment, so any subsequent comment numbers will be shifted ***
Attachment #8354153 - Flags: review?(aleth) → review+
*** Original post on bio 1938 at 2013-04-19 00:24:21 UTC ***

http://hg.instantbird.org/instantbird/rev/026a99aba2f8

This seems to fix the crash in bug 955365 (bio 1928), but let's try it in a nightly for a few days.
Assignee: nobody → florian
Status: NEW → RESOLVED
Closed: 8 years ago
OS: Other → All
Hardware: x86 → All
Resolution: --- → FIXED
Target Milestone: --- → 1.4
*** Original post on bio 1938 at 2013-04-19 10:34:02 UTC ***

Adding this as it's informative about "why target the status observer":
23:44:17 <flo-retina> I wanted any of the lines in http://lxr.instantbird.org/instantbird/source/chat/components/src/imAccounts.js#271 to evaluate to false
23:44:48 <flo-retina> the first one seemed the easier to target as it was something I could actually uninitialize
23:45:28 <flo-retina> I could also have changed this.statusInfo.statusType to OFFLINE or UNKNOWN, but that could potentially fire lots of notifications and I wouldn't want to risk that so close to a release
You need to log in before you can comment on or make changes to this bug.