Consider requesting Nvidia to add Instantbird to the 'Mozilla Firefox' profile in their drivers

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
5 years ago
3 years ago

People

(Reporter: bugzilla, Unassigned)

Tracking

trunk
x86
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

5 years ago
*** Original post on bio 1963 by Emanuel Hoogeveen <emanuel.hoogeveen AT gmail.com> at 2013-05-21 18:13:00 UTC ***

Nvidia drivers include profiles with various program-specific settings that override the global settings. Among these is a profile for Mozilla Firefox that sets various flags to ensure its hardware acceleration works correctly.

When I first installed Instantbird, all text in the program appeared blurry. As it looked like a bad case of grayscale anti-aliasing, I went hunting through the options (including about:config) to find how it differed from Firefox, but found nothing. It then occurred to me to try copying the Nvidia profile for Mozilla Firefox, using NVIDIA Inspector, so that it would be applied to instantbird.exe - and this fixed the problem.

I think this may be caused by a specific global setting which enables FXAA by default, a pixel-shader based version of anti-aliasing. This setting appears to be explicitly disabled in the Firefox profile - however, I have not yet confirmed that it is to blame.

Regardless of the particular setting to blame, however, it seems to me like Instantbird might benefit wholesale from being included in the Nvidia profile for Firefox, since it is based on the same engine. As such, I suggest contacting Nvidia to see if they would be willing to extend the Mozilla Firefox profile to apply to instantbird.exe as well. That wouldn't fix issues in existing drivers, but would avoid the problem going forward.
*** Original post on bio 1963 at 2013-05-21 18:25:49 UTC ***

Submitted to nvidia via http://nvidia-submit.custhelp.com/app/answers/list
(Reporter)

Comment 2

5 years ago
*** Original post on bio 1963 by Emanuel Hoogeveen <emanuel.hoogeveen AT gmail.com> at 2013-05-21 18:49:30 UTC ***

I've confirmed that the blurry text is fixed by the part of the Firefox profile that sets "NVIDIA Predefined FXAA Usage" (a hidden setting shown by Nvidia Inspector) to Disabled. There are 7 flags in total in the Firefox profile, however, and the others might well prevent other issues.
I never received any response from this. If it's still a problem, let us know and we can try submitting again.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.