Unable to authenticate with IRC server using LDAP authentication

RESOLVED WORKSFORME

Status

Chat Core
IRC
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: Instantbot, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
*** Original post on bio 1971 by gringochapin <cannona AT gmail.com> at 2013-05-23 20:56:00 UTC ***

For the IRC log where this was discussed at length, please see http://log.bezut.info/instantbird/130523/ starting at about 17:17.

The server is using Atheme and Inspirecd.  The same credentials work with other chat clients connecting to the same IRC server.

I set messenger.account.account5.options.username to the appropriate user name.

It should be noted that downgrading to Instantbird 1.1 solves this issue, and I am able to connect to this server.

The log follows:

[5/23/2013 1:30:31 PM] LOG   (@ prpl-irc resource:///modules/socket.jsm:148)
Connecting to: irc.xxx.com:6697
[5/23/2013 1:30:31 PM] DEBUG (@ prpl-irc resource:///modules/socket.jsm:457)
onTransportStatus(STATUS_RESOLVING)
[5/23/2013 1:30:31 PM] DEBUG (@ prpl-irc resource:///modules/socket.jsm:457)
onTransportStatus(STATUS_RESOLVED)
[5/23/2013 1:30:31 PM] DEBUG (@ prpl-irc resource:///modules/socket.jsm:457)
onTransportStatus(STATUS_CONNECTING_TO)
[5/23/2013 1:30:31 PM] DEBUG (@ prpl-irc resource:///modules/socket.jsm:457)
onTransportStatus(STATUS_CONNECTED_TO)
[5/23/2013 1:30:31 PM] LOG   (@ prpl-irc resource:///modules/socket.jsm:242)
Sending:
CAP LS

[5/23/2013 1:30:31 PM] LOG   (@ prpl-irc resource:///modules/socket.jsm:242)
Sending:
NICK myusername

[5/23/2013 1:30:31 PM] LOG   (@ prpl-irc resource:///modules/socket.jsm:242)
Sending:
USER myusername 0 * myusername

[5/23/2013 1:30:31 PM] DEBUG (@ prpl-irc resource:///modules/socket.jsm:457)
onTransportStatus(STATUS_SENDING_TO)
[5/23/2013 1:30:31 PM] DEBUG (@ prpl-irc resource:///modules/socket.jsm:457)
onTransportStatus(STATUS_RECEIVING_FROM)
[5/23/2013 1:30:31 PM] DEBUG (@ prpl-irc resource:///modules/socket.jsm:399)
onStartRequest
[5/23/2013 1:30:31 PM] DEBUG (@ prpl-irc jar:file:///C:/Program%20Files/Instantbird/omni.ja!/components/irc.js:621)
:irc.xxx.com NOTICE Auth :*** Looking up your hostname...
[5/23/2013 1:30:31 PM] DEBUG (@ prpl-irc resource:///modules/ircHandlers.jsm:104)
{"rawMessage":":irc.xxx.com NOTICE Auth :*** Looking up your hostname...","command":"NOTICE","params":["Auth","*** Looking up your hostname..."],"servername":"irc.xxx.com"}
[5/23/2013 1:30:31 PM] DEBUG (@ prpl-irc jar:file:///C:/Program%20Files/Instantbird/omni.ja!/components/irc.js:621)
:irc.xxx.com NOTICE Auth :*** Found your hostname (mainframe.xxx.com) -- cached
[5/23/2013 1:30:31 PM] DEBUG (@ prpl-irc resource:///modules/ircHandlers.jsm:104)
{"rawMessage":":irc.xxx.com NOTICE Auth :*** Found your hostname (mainframe.xxx.com) -- cached","command":"NOTICE","params":["Auth","*** Found your hostname (mainframe.xxx.com) -- cached"],"servername":"irc.xxx.com"}
[5/23/2013 1:30:31 PM] DEBUG (@ prpl-irc resource:///modules/socket.jsm:457)
onTransportStatus(STATUS_RECEIVING_FROM)
[5/23/2013 1:30:31 PM] DEBUG (@ prpl-irc jar:file:///C:/Program%20Files/Instantbird/omni.ja!/components/irc.js:621)
:irc.xxx.com CAP 269AAQPNB LS :sasl tls
[5/23/2013 1:30:31 PM] LOG   (@ prpl-irc resource:///modules/socket.jsm:242)
Sending:
CAP REQ sasl

[5/23/2013 1:30:31 PM] DEBUG (@ prpl-irc resource:///modules/ircHandlers.jsm:104)
{"rawMessage":":irc.xxx.com CAP 269AAQPNB LS :sasl tls","command":"CAP","params":["269AAQPNB","LS","sasl tls"],"servername":"irc.xxx.com","cap":{"subcommand":"LS","parameter":"sasl","disable":false,"sticky":false,"ack":false}}
[5/23/2013 1:30:31 PM] WARN. (@ prpl-irc resource:///modules/ircCAP.jsm:76)
Unhandled CAP messages: tls
Raw message: :irc.xxx.com CAP 269AAQPNB LS :sasl tls
[5/23/2013 1:30:31 PM] DEBUG (@ prpl-irc resource:///modules/ircHandlers.jsm:104)
{"rawMessage":":irc.xxx.com CAP 269AAQPNB LS :sasl tls","command":"CAP","params":["269AAQPNB","LS","sasl tls"],"servername":"irc.xxx.com","cap":{"subcommand":"LS"}}
[5/23/2013 1:30:31 PM] DEBUG (@ prpl-irc jar:file:///C:/Program%20Files/Instantbird/omni.ja!/components/irc.js:621)
ERROR :Closing link: (myusername@mainframe.xxx.com) [LDAP authentication failed. Access denied]
[5/23/2013 1:30:31 PM] ERROR (@ prpl-irc resource:///modules/ircBase.jsm:169)
Received unexpected ERROR response:
Closing link: (myusername@mainframe.xxx.com) [LDAP authentication failed. Access denied]
[5/23/2013 1:30:31 PM] LOG   (@ prpl-irc resource:///modules/socket.jsm:181)
Disconnect
[5/23/2013 1:30:31 PM] DEBUG (@ prpl-irc resource:///modules/ircHandlers.jsm:104)
{"rawMessage":"ERROR :Closing link: (myusername@mainframe.xxx.com) [LDAP authentication failed. Access denied]","command":"ERROR","params":["Closing link: (myusername@mainframe.xxx.com) [LDAP authentication failed. Access denied]"]}
[5/23/2013 1:30:31 PM] DEBUG (@ prpl-irc resource:///modules/socket.jsm:403)
onStopRequest (0)
[5/23/2013 1:30:31 PM] DEBUG (@ prpl-irc resource:///modules/socket.jsm:457)
onTransportStatus(STATUS_SENDING_TO)

Updated

4 years ago
OS: Windows XP → All
Hardware: x86 → All

Comment 1

4 years ago
*** Original post on bio 1971 at 2013-05-25 09:54:36 UTC ***

Can you try the following: In about.config, create a pref "messenger.account.account#.options.serverPassword" and set it to your password (where # is the number of the account). Then try to connect and attach the debug log if it fails.
(Reporter)

Comment 2

4 years ago
Created attachment 8354225 [details]
With the messenger.account.account9.options.serverPassword option set to my password.

*** Original post on bio 1971 as attmnt 2458 by cannona AT gmail.com at 2013-05-25 13:39:00 UTC was without comment, so any subsequent comment numbers will be shifted ***
*** Original post on bio 1971 at 2013-05-30 12:10:41 UTC ***

Now it looks like we're waiting for the sasl module to respond with AUTHENTICATE + (see https://raw.github.com/atheme/atheme/master/doc/SASL)

Did you also have a normal password set? You could try not including that (and just setting serverPassword).

It would be extremely helpful to have a log from a "correct" connection.
(Reporter)

Comment 4

4 years ago
*** Original post on bio 1971 by gringochapin <cannona AT gmail.com> at 2013-05-30 13:47:42 UTC ***

Any suggestions on how to accomplish this?  I.E. which client will allow me to log the negotiations, and how?

Thanks much!
*** Original post on bio 1971 at 2013-05-30 15:31:28 UTC ***

You could try using Pidgin's debug log (see [1]), but I'm unsure how detailed it is (will it at least show us the commands sent?)

Other IRC clients show every command in a "console" tab. (ChatZilla might do this?)

[1] https://developer.pidgin.im/wiki/TipsForBugReports#ObtainingaDebugLog
(Reporter)

Comment 6

4 years ago
*** Original post on bio 1971 by gringochapin <cannona AT gmail.com> at 2013-05-30 22:53:34 UTC ***

Removing the password in the account properties dialog, and with the serverPassword option and the username options set in about:config solves the issue.  I am now able to connect!  Thanks tons for working through this with me.  If there is something I can do to help get this issue resolved, please don't hesitate to let me know.
*** Original post on bio 1971 at 2013-05-31 01:07:11 UTC ***

I think this is just a weird server set up where you HAVE to provide the PASS command (even though it says it supports SASL), that's why we added the serverPassword option! :)

If I think of something else, I'll let you know. Thanks for working through this with us.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.