Closed Bug 955446 Opened 7 years ago Closed 7 years ago

Some JS errors when joining some IRC channels

Categories

(Chat Core :: IRC, defect)

x86
Other
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: florian, Unassigned)

Details

Attachments

(1 file)

*** Original post on bio 2010 at 2013-06-20 23:16:00 UTC ***

*** Due to BzAPI limitations, the initial description is in comment 1 ***
*** Original post on bio 2010 as attmnt 2496 at 2013-06-20 23:16:00 UTC ***

Timestamp: 20/06/13 11:13:57
Error: [Exception... "'Adding chat buddy jb twice?!' when calling method: [nsIObserver::observe]"  nsresult: "0x8057001e (NS_ERROR_XPC_JS_THREW_STRING)"  location: "JS frame :: resource:///modules/jsProtoHelper.jsm :: <TOP_LEVEL> :: line 412"  data: no]
Source File: resource:///modules/jsProtoHelper.jsm
Line: 412

Timestamp: 20/06/13 11:13:57
Error: Error running command JOIN with handler RFC 2812:
{"rawMessage":":jb!Thunderbir@moz-801E009D.vlan502.asr1.cdg2.gblx.net JOIN :#webrtc-apps","command":"JOIN","params":["#webrtc-apps"],"nickname":"jb","user":"Thunderbir","host":"moz-801E009D.vlan502.asr1.cdg2.gblx.net","source":"Thunderbir@moz-801E009D.vlan502.asr1.cdg2.gblx.net"}
'Adding chat buddy jb twice?!' when calling method: [nsIObserver::observe]
Source File: resource:///modules/ircHandlers.jsm
Line: 412
Source Code:
prpl-irc

Timestamp: 20/06/13 13:32:30
Error: [Exception... "'Adding chat buddy Standard8 twice?!' when calling method: [nsIObserver::observe]"  nsresult: "0x8057001e (NS_ERROR_XPC_JS_THREW_STRING)"  location: "JS frame :: resource:///modules/jsProtoHelper.jsm :: <TOP_LEVEL> :: line 412"  data: no]
Source File: resource:///modules/jsProtoHelper.jsm
Line: 412

Timestamp: 20/06/13 13:32:30
Error: Error running command JOIN with handler RFC 2812:
{"rawMessage":":Standard8!Standard8@moz-801E009D.vlan502.asr1.cdg2.gblx.net JOIN :#talkilla","command":"JOIN","params":["#talkilla"],"nickname":"Standard8","user":"Standard8","host":"moz-801E009D.vlan502.asr1.cdg2.gblx.net","source":"Standard8@moz-801E009D.vlan502.asr1.cdg2.gblx.net"}
'Adding chat buddy Standard8 twice?!' when calling method: [nsIObserver::observe]
Source File: resource:///modules/ircHandlers.jsm
Line: 412
Source Code:
prpl-irc

Timestamp: 20/06/13 23:39:04
Error: [Exception... "'Cannot remove a buddy that was not in the room' when calling method: [nsIObserver::observe]"  nsresult: "0x8057001e (NS_ERROR_XPC_JS_THREW_STRING)"  location: "JS frame :: resource:///modules/jsProtoHelper.jsm :: <TOP_LEVEL> :: line 412"  data: no]
Source File: resource:///modules/jsProtoHelper.jsm
Line: 412

Timestamp: 20/06/13 23:39:04
Error: Error running command JOIN with handler RFC 2812:
{"rawMessage":":flo-retina!Instantbir@moz-87C33FDA.kimsufi.com JOIN :#talkilla","command":"JOIN","params":["#talkilla"],"nickname":"flo-retina","user":"Instantbir","host":"moz-87C33FDA.kimsufi.com","source":"Instantbir@moz-87C33FDA.kimsufi.com"}
'Cannot remove a buddy that was not in the room' when calling method: [nsIObserver::observe]
Source File: resource:///modules/ircHandlers.jsm
Line: 412
Source Code:
prpl-irc


This causes the "left" icon to stay displayed on the #talkilla channel.

The attached patch doesn't fix the bug, but should improve the debugging messages we get, which hopefuly will help us identify the root cause.

r+'ed by clokep over IRC.
Attachment #8354263 - Flags: review+
*** Original post on bio 2010 at 2013-06-20 23:53:43 UTC ***

Checked in as http://hg.instantbird.org/instantbird/rev/56488a23fd22
Assignee: nobody → florian
I don't remember seeing this recently, should we resolve as WORKSFORME?
Assignee: florian → nobody
(In reply to Florian Quèze [:florian] [:flo] from comment #3)
> I don't remember seeing this recently, should we resolve as WORKSFORME?

I've never seen this either, so resolving for now.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
See Also: → 1118515
See Also: 1118515
this.ERROR not being defined in a test is a different issue.
You need to log in before you can comment on or make changes to this bug.