Closed Bug 955531 Opened 6 years ago Closed 6 years ago

Required key 52 wasn't found.

Categories

(Chat Core :: Yahoo! Messenger, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: aleth, Assigned: qheaden)

References

Details

Attachments

(1 file)

*** Original post on bio 2094 at 2013-08-02 11:54:00 UTC ***

Timestamp: 08/02/2013 01:51:55 PM
Error: Required key 52 wasn't found. Packet Service: 1c
Source File: resource:///modules/yahoo-session.jsm
Line: 345
Source Code:
prpl-yahoo

STR unclear (but I was trying to join a chatroom).
Duplicate of this bug: 955556
*** Original post on bio 2094 at 2013-08-21 15:30:53 UTC ***

(In reply to bug 955556 (bio 2118), comment #0)
> Timestamp: 08/21/2013 05:21:55 PM
> Error: Required key 52 wasn't found. Packet Service: 1c
> Source File: resource:///modules/yahoo-session.jsm
> Line: 386
> Source Code:
> prpl-yahoo
> 
> STR: /invite clokep,qheaden Here's a yahoo conference
Attached patch Patch 1Splinter Review
*** Original post on bio 2094 as attmnt 2748 at 2013-08-22 06:39:00 UTC ***

This patch fixes the issue. Unfortunately, in this case, it seems that the Yahoo servers are sending back two ack packets. One of the ack packets has a strange status number, and it contains only the name of the invitee and host. Such an ack really doesn't matter to us since we already know the details of the invitation once we receive the ack.

This patch simply ignores the ack packets, and only processes the initial invitation packet.
Attachment #8354517 - Flags: review?(clokep)
Assignee: nobody → qheaden
Status: NEW → ASSIGNED
*** Original post on bio 2094 at 2013-08-22 09:11:08 UTC ***

Have you experimented to see if the returned ack packets somehow correspond to whether the invitations were sent successfully? Is it a coincidence that we get two ack packets for STR that send an invite to two users?
*** Original post on bio 2094 at 2013-08-23 03:06:38 UTC ***

I just experimented, and the ack packet is sent back regardless of whether the invite was successful or not; this included inviting users who don't exist. Also, I made a mistake in saying that two ack packets are returned. I was using WireShark on official Yahoo client and Instantbird running on the same machine, so it was confusing to recognize traffic for one chat client over the other. This report I am writing has been observed using two different machines.

Basically, our only way of knowing our invite was successful is if the user joins our conference. Other than that, from what I see, the protocol provides no information on that.
Comment on attachment 8354517 [details] [diff] [review]
Patch 1

*** Original change on bio 2094 attmnt 2748 at 2013-08-23 12:24:06 UTC was without comment, so any subsequent comment numbers will be shifted ***
Attachment #8354517 - Flags: review?(clokep) → review+
Whiteboard: [checkin-needed]
*** Original post on bio 2094 at 2013-08-23 21:48:10 UTC ***

http://hg.instantbird.org/instantbird/rev/373af5342a33
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [checkin-needed]
Target Milestone: --- → 1.5
You need to log in before you can comment on or make changes to this bug.