Triple clicking the Details links of the Update history dialog quits Instantbird

RESOLVED FIXED in 1.5

Status

--
critical
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: florian, Assigned: florian)

Tracking

trunk
All
Other

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
*** Original post on bio 2127 at 2013-08-26 09:55:00 UTC ***

Steps to reproduce: in the pref window, go to advanced->update->Show Update History. Triple click on the "Details" link. Boom, your Instantbird is gone. This is not a crash, the bot's log shows a quit message.

I tested on Mac, and aleth confirmed (on Linux I guess), so not a platform specific issue.

Comment 1

5 years ago
*** Original post on bio 2127 at 2013-08-26 09:58:04 UTC ***

Also: Single click -> "No chrome package registered for chrome://navigator/content/navigator.xul" in the error console" (and no other effect) -> Crash on closing the update history window.
(Assignee)

Comment 2

5 years ago
*** Original post on bio 2127 at 2013-08-26 10:05:39 UTC ***

A single click causes this message in the Error Console:
"No chrome package registered for chrome://navigator/content/navigator.xul"

This seems to indicate we are at:
http://mxr.mozilla.org/mozilla-release/source/xpfe/appshell/src/nsXULWindow.cpp#1777
1777   nsAdoptingCString urlStr = Preferences::GetCString("browser.chromeURL");
1778   if (urlStr.IsEmpty()) {
1779     urlStr.AssignLiteral("chrome://navigator/content/navigator.xul");
1780   }
(Assignee)

Comment 3

5 years ago
*** Original post on bio 2127 at 2013-08-26 19:01:34 UTC ***

To make the Details links work, it looks like we need to observe the handle-xul-text-link notification: http://mxr.mozilla.org/mozilla-central/source/toolkit/content/widgets/text.xml#360
(Assignee)

Comment 4

5 years ago
Created attachment 8354560 [details] [diff] [review]
Patch

*** Original post on bio 2127 as attmnt 2791 at 2013-08-26 22:54:00 UTC ***

I debugged the quit situation a bit, here's what I said on IRC:
21:12:56 - flo-retina: I've debugged a bit our crazy quit bug; it's interesting.
21:13:13 - flo-retina: Every click attempts to open a window, and that attempt fails, so the 'new window' is closed.
21:14:10 - flo-retina: nsAppStartup maintains a count of how many opened window we have. When that count reaches 0, the application exits.
21:14:32 - flo-retina: so to quit Instantbird from the "Details" links, you need to make as many clicks as you have opened windows at the time
21:14:54 - flo-retina: so the problem is that we are closing windows that have never been opened

I don't think I'll have time to properly finish this debugging (it's definitely a platform bug), so I'm inclined to instead just fix the Instantbird bug (comment 3).
Attachment #8354560 - Flags: review?(clokep)
(Assignee)

Updated

5 years ago
Assignee: nobody → florian
Status: NEW → ASSIGNED
Comment on attachment 8354560 [details] [diff] [review]
Patch

*** Original change on bio 2127 attmnt 2791 at 2013-08-27 03:14:17 UTC ***

Be nice to figure out the platform issue...but really just getting it working is the priority. Thanks for looking at this. Should we at least file a Mozilla bug?
Attachment #8354560 - Flags: review?(clokep) → review+
(Assignee)

Comment 6

5 years ago
*** Original post on bio 2127 at 2013-08-27 08:29:06 UTC ***

http://hg.instantbird.org/instantbird/rev/c673a1937cf1

(In reply to comment #5)
> Should we at least file a Mozilla bug?

The first step is to create a reduced test case.
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.5
(Assignee)

Comment 7

5 years ago
*** Original post on bio 2127 at 2013-08-27 22:44:44 UTC ***

I filed https://bugzilla.mozilla.org/show_bug.cgi?id=909976

Unfortunately, given that the steps to reproduce require setting the browser.chromeURL preference to a value that would never exist for Firefox, I would be surprised if any action happened there.
You need to log in before you can comment on or make changes to this bug.