Closed Bug 955587 Opened 6 years ago Closed 6 years ago

Remove VKontakte protocol

Categories

(Chat Core :: General, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: bugzilla, Assigned: clokep)

Details

(Whiteboard: [1.5-blocking])

Attachments

(2 files)

*** Original post on bio 2148 by Alexander L. Slovesnik <unghost AT gmail.com> at 2013-09-02 22:16:00 UTC ***

VKontakte has decided to drop XMPP support. http://vk.com/help.php?page=jabber states "XMPP protocol support has been discontinued! Please use the website and the official mobile clients." Therefore, its support should be removed from Instantbird.
*** Original post on bio 2148 at 2013-09-02 23:19:31 UTC ***

I think this will be the first time we drop a protocol that wasn't distributed as an add-on. I wonder if we need to polish a bit the 'unknown protocol' handler for 1.5.
Whiteboard: [1.5-blocking]
*** Original post on bio 2148 at 2013-09-03 01:00:14 UTC ***

It would be more awesome if someone were to add support for their custom API: http://vk.com/dev/methods
Attached patch WIP v1Splinter Review
*** Original post on bio 2148 as attmnt 2976 at 2013-10-23 03:09:00 UTC ***

This gets half-way through the OAuth progress, but then ends up at an error page. I can't really figure out why (manually going through the URLs in a browser seems to work...). Any ideas would be appreciated.
Assignee: nobody → clokep
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Whiteboard: [1.5-blocking] → [1.5-blocking][needs patch clokep]
Attached patch Remove vkSplinter Review
*** Original post on bio 2148 as attmnt 3090 at 2013-11-28 13:06:00 UTC ***

This removes VK, I haven't actually tested it fully since my build doesn't seem to work after doing this (it's complaining about the vk directory not existing anymore...I'm pretty sure this is just me not understanding what the deal is with rebuilding now that we have moz.build).
Attachment #8354872 - Flags: review?(florian)
Comment on attachment 8354872 [details] [diff] [review]
Remove vk

*** Original change on bio 2148 attmnt 3090 at 2013-11-28 18:34:44 UTC ***

Seems fine, thanks.

Note: during the review I wondered if we needed to add the .js and .manifest files to removed-files.in; but all these JS components are part of omni.ja these days, so I don't think we need to explicitly remove them.
Attachment #8354872 - Flags: review?(florian) → review+
*** Original post on bio 2148 at 2013-11-29 03:13:03 UTC ***

http://hg.instantbird.org/instantbird/rev/a9daa2b6c60f

If someone is interested in cleaning up that WIP to finish it, let me know and file a new bug.
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [1.5-blocking][needs patch clokep] → [1.5-blocking]
Target Milestone: --- → 1.5
*** Original post on bio 2148 at 2013-11-29 14:19:53 UTC ***

Bustage follow up: http://hg.instantbird.org/instantbird/rev/291d2e0f43f5
You need to log in before you can comment on or make changes to this bug.