Last Comment Bug 95560 - Return "UTF-8" for nsIPlatformCharset while pass kPlatformCharsetSel_FileName
: Return "UTF-8" for nsIPlatformCharset while pass kPlatformCharsetSel_FileName
Status: RESOLVED FIXED
: intl
Product: Core
Classification: Components
Component: Internationalization (show other bugs)
: Trunk
: PowerPC Mac OS X
: -- normal (vote)
: ---
Assigned To: nhottanscp
: Yuying Long
: Makoto Kato [:m_kato]
Mentors:
Depends on:
Blocks: 103669 108000
  Show dependency treegraph
 
Reported: 2001-08-16 00:45 PDT by Frank Tang
Modified: 2005-07-25 11:40 PDT (History)
10 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch, not fully tested yet. (1.32 KB, patch)
2001-08-16 13:26 PDT, Frank Tang
no flags Details | Diff | Splinter Review

Description Frank Tang 2001-08-16 00:45:46 PDT
While calling nsIPlatformCharset
 with kPlatformCharsetSel_FileName on Macintosh, we currently return the charset
name of the system script.
Since MacOS X use UTF-8 for all the char* function of BSD file system functions
and define the file:/// URL as % escaped UTF-8, we probably should return
"UTF-8" on MacOS X instead.

see bug 95478 and 95481 for more information.
Comment 1 Frank Tang 2001-08-16 13:26:43 PDT
Created attachment 46104 [details] [diff] [review]
patch, not fully tested yet.
Comment 2 Kathleen Brade 2001-08-16 14:32:45 PDT
fix spacing, remove tabs from the lines you are adding, test various OS versions
if you don't find any problems, r=brade
Comment 3 Frank Tang 2001-08-21 15:40:35 PDT
This is a very very risky move. Code is simple the change is huge. move it to m95
Comment 4 Frank Tang 2001-10-08 10:45:02 PDT
move to m0.9.7
Comment 5 nhottanscp 2001-11-20 13:51:38 PST
move to 0.9.8

Comment 6 nhottanscp 2001-11-20 13:55:02 PST
http://developer.apple.com/techpubs/macosx/Essentials/SystemOverview/FileSystem/File_Encodings_and_Fonts.html

According to the document, BSD uses UTF-8 but HFS+ uses UTF-16.
Comment 7 Frank Tang 2002-01-16 18:08:00 PST
mass move to m9.9
Comment 8 Frank Tang 2002-02-12 19:51:06 PST
give this to nhotta, remove target
Comment 9 Masayuki Nakano [:masayuki] (Mozilla Japan) 2005-07-25 11:40:04 PDT
This has been fixed by bug 199384.
-> FIXED

Note You need to log in before you can comment on or make changes to this bug.