If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

package-manifest:35: Missing file(s): bin/uninstall/helper.exe

RESOLVED FIXED in 1.5

Status

Instantbird
Other
--
major
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: florian, Assigned: clokep)

Tracking

trunk
x86
Windows XP

Details

(Whiteboard: [1.5-blocking][possible regression])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
*** Original post on bio 2189 at 2013-09-30 12:38:00 UTC ***

On Windows 'make package' produces this warning (among others):
Warning: e:\bb-slave\win32\obj-instantbird\instantbird\installer\package-manifest:35: Missing file(s): bin/uninstall/helper.exe

I think we need to check if this is just noise or breaks the uninstall path before releasing any new version.
(Reporter)

Updated

4 years ago
Whiteboard: [1.5-blocking][possible regression]
(Reporter)

Comment 1

4 years ago
*** Original post on bio 2189 at 2013-09-30 12:40:42 UTC ***

Note: this is NOT caused by the moz24 update. I looked further in older buildbot logs, and builds based on moz23 and even moz22 have this warning.
(Assignee)

Comment 2

4 years ago
*** Original post on bio 2189 at 2013-11-11 13:26:27 UTC ***

This is from [1], which is Mozilla 14!

[1] Bio 604266 - Remove '--disable-installer' option and 'MOZ_INSTALLER' variable: https://bugzilla.mozilla.org/show_bug.cgi?id=604266

Patch coming soon.
Assignee: nobody → clokep
Severity: normal → major
Status: NEW → ASSIGNED
(Assignee)

Comment 3

4 years ago
Created attachment 8354811 [details] [diff] [review]
Patch

*** Original post on bio 2189 as attmnt 3030 at 2013-11-11 13:28:00 UTC ***

I checked and this is the only usage of MOZ_INSTALLER in Instantbird.
Attachment #8354811 - Flags: review?(florian)
(Assignee)

Comment 4

4 years ago
*** Original post on bio 2189 at 2013-11-11 13:29:34 UTC ***

Also, IB 1.2 was the version released on Mozilla 14, so it's possible we haven't had an uninstaller since then?
(Assignee)

Updated

4 years ago
Blocks: 955017
(Reporter)

Comment 5

4 years ago
Comment on attachment 8354811 [details] [diff] [review]
Patch

*** Original change on bio 2189 attmnt 3030 at 2013-11-11 15:04:36 UTC ***

Thanks!
Attachment #8354811 - Flags: review?(florian) → review+
(Assignee)

Comment 6

4 years ago
*** Original post on bio 2189 at 2013-11-11 15:51:10 UTC ***

http://hg.instantbird.org/instantbird/rev/0762f55e4717
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.5
You need to log in before you can comment on or make changes to this bug.