No update of Mac nightlies

RESOLVED FIXED

Status

Instantbird Servers
update.instantbird.org
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: florian, Unassigned)

Tracking

Details

(Reporter)

Description

4 years ago
*** Original post on bio 554 at 2010-10-17 11:45:00 UTC ***

My mac nightly hasn't received any update for a few days, even though the builds were successful on buildbot.

Example of an update request that doesn't receive an update offer:
https://update.instantbird.org/1/Instantbird/0.3a1pre/20101012173516/Darwin_x86-gcc3-u-ppc-i386/en-US/nightly/Darwin%209.8.0/update.xml?force=1

Comment 1

4 years ago
*** Original post on bio 554 at 2010-10-17 13:26:07 UTC ***

I just tried to flush the cache and it did the trick. I looked into the cache management code to find out if something looks wrong there.

I found this :
$rm_path = config_file::get()->get_value('update', 'apache_dir').
  '*/Instantbird/*/*/'.$mi['arch'].'/'.$mi['lng'];
  `/usr/local/bin/bash -c "/bin/rm -Rf $rm_path"`;

I looks very bad now because arch is not what it should on Mac. I'll just flush the whole cache and it should be OK. Sadly, I don't see any better way of doing this...

Comment 2

4 years ago
*** Original post on bio 554 at 2010-10-17 13:27:00 UTC ***

Here is the new cache deleting code:
$rm_path = config_file::get()->get_value('update', 'apache_dir').
  '*/Instantbird/*/*/*/'.$mi['lng'];

Now it should work.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Reporter)

Comment 3

4 years ago
*** Original post on bio 554 at 2010-10-17 13:31:52 UTC ***

(In reply to comment #1)

> I looks very bad now because arch is not what it should on Mac. I'll just flush
> the whole cache and it should be OK. Sadly, I don't see any better way of doing
> this...

If you would rather flush only the cache for the architecture, it may be possible check if it's a mac architecture (if starts with "Darwin_") and in that case replace the content of $mi['arch'] with "Darwin_*".

I'm not too concerned with flushing the whole cache though.

Comment 4

4 years ago
*** Original post on bio 554 at 2010-10-17 13:37:14 UTC ***

Yeah me neither. It's not like there will be any great flaw of performances caused by this. The generation of an update file takes less than 1 second and is put in cache instantly after bypassing PHP completely thus insuring a very good trade of for performances. I'm happy with the actual line that flush everything for the language.

I consider this bug closed until another parameter change the situation about this.
You need to log in before you can comment on or make changes to this bug.