Failing to apply update immediately because "Instantbird is still running", before: "instantbird Automated Update broken"

RESOLVED WORKSFORME

Status

Instantbird
Other
--
minor
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: Instantbot, Unassigned)

Tracking

trunk
All
Windows 7

Details

(Reporter)

Description

4 years ago
*** Original post on bio 641 by Donnie Muurdock <dgmurdockiii AT gmail.com> at 2010-12-26 19:44:00 UTC ***

When i do the update most of the time when it ask me to restart to install the update it will ether fail the partial update and ask to do full update but that dose not happen  often most of the time it will not work saying that wehn it tryed install the update when i click restart instantbird that it was running so the update could not be completed so if i close instantbird then open it it will work no problem
(Reporter)

Updated

4 years ago
Component: update.instantbird.org → Other
Product: Instantbird Servers → Instantbird
Version: unspecified → trunk
(Reporter)

Updated

4 years ago
Severity: critical → blocker

Comment 1

4 years ago
*** Original post on bio 641 at 2011-01-04 08:44:36 UTC ***

This is a duplicate. Please try to look into the existing bugs before opening a new one.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 953989
*** Original post on bio 641 at 2011-01-17 19:36:35 UTC ***

After talking to the bug reporter on IRC I think this is not bug 953989 (bio 551).

The reporter experiences the following:

"Click to restart" -> restarting -> "Instantbird in use, try later" -> trying again later -> applying update -> works

No full update is downloaded during the process.

It seems to me that Instantbird hasn't fully closed/cleaned up when the updater tries to apply the update.

(My own compuer is rather slow. I frequently get a "profile in use" error on Firefox if I close it and try to restart it the next moment. Maybe this is the same thing, only affecting an update this time?)
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Summary: instantbird Automated Update broken → Failing to apply update immediately because "Instantbird is still running", before: "instantbird Automated Update broken"
*** Original post on bio 641 at 2011-01-28 16:11:15 UTC ***

There's an easy workaround (close the application and wait a few seconds before starting it again) -> setting severity to minor.
Severity: blocker → minor

Comment 4

4 years ago
*** Original post on bio 641 at 2012-02-16 23:50:53 UTC ***

Could the original reporter confirm whether this still happens with Instantbird 1.1 or a recent nightly?

Comment 5

4 years ago
*** Original post on bio 641 at 2012-04-11 20:07:59 UTC ***

There seem to have been no further reports of this happening, so closing this for now.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.