The reporter has too many permissions

CLOSED DUPLICATE of bug 90619

Status

()

Bugzilla
Creating/Changing Bugs
P3
normal
CLOSED DUPLICATE of bug 90619
17 years ago
6 years ago

People

(Reporter: Roni Abusch, Assigned: myk)

Tracking

2.13
x86
Windows 2000

Details

(Whiteboard: [permissions:edit])

(Reporter)

Description

17 years ago
How can I disable the reporter of the bug from having the below options?

 Leave as ASSIGNED 
 Resolve bug, changing resolution to
 Resolve bug, mark it as duplicate of bug
 Reassign bug to  
 Reassign bug to owner and QA contact of selected component
(Reporter)

Comment 1

17 years ago
I've hacked the code in my installation to do it.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
that doesn't mean we don't want to fix it in the distribution code, though.

Although since your patches probably didn't provide an option for it, and just
did it directly, they may be worth submitting anyway, just so we can see what
all had to be done.  We may have to change it to make it optional, but it'd
still be useful I think.

Sorry if it seemed like we were taking a while to get to these - we're right in
the middle of wrapping up the 2.14 release cycle.  In another week or so we'll
be getting back to triaging all the reports again.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
(Reporter)

Comment 3

17 years ago
In bug_form.pl I've removed the reporter from the previledged:
if ($canedit || $::userid == $assignedtoid || $::userid == $qacontactid) {
    if (IsOpenedState($status)) {
        if ($status ne "ASSIGNED") {
...

Comment 4

17 years ago
-> Bugzilla product, Creating Bugs component, reassigning.
Assignee: justdave → myk
Status: REOPENED → NEW
Component: Bugzilla → Creating/Changing Bugs
Product: Webtools → Bugzilla
Whiteboard: [permissions:edit]
Version: Bugzilla 2.13 → 2.13
Priority: -- → P3
Target Milestone: --- → Bugzilla 2.20

Comment 5

17 years ago
This similar to bug#90619

*** This bug has been marked as a duplicate of 90619 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago16 years ago
Resolution: --- → DUPLICATE
clearing target on DUPLICATE/WONTFIX/INVALID/WORKSFORME so they'll show up as
untriaged if they get reopened.
Target Milestone: Bugzilla 2.20 → ---
(Reporter)

Comment 8

16 years ago
OK, let's close it...
Status: RESOLVED → CLOSED

Updated

8 years ago
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.