There is no prompt window on a return receipt request

RESOLVED FIXED in seamonkey2.26

Status

defect
--
major
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: chokito, Assigned: InvisibleSmiley)

Tracking

({regression})

SeaMonkey Tracking Flags

(seamonkey2.23 wontfix, seamonkey2.24 fixed, seamonkey2.25 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:28.0) Gecko/20100101 Firefox/28.0 SeaMonkey/2.25a2 (Beta/Release)
Build ID: 20131230013001

Steps to reproduce:

The receipt of a return receipt does not recognized.

User agent: Mozilla/5.0 (Windows NT 5.1; rv:28.0) Gecko/20100101 Firefox/28.0 SeaMonkey/2.25a2
Build identifier: 20131230013001


Actual results:

None.


Expected results:

The prompt window should be opened.
(Reporter)

Comment 1

5 years ago
"mail.mdn.report.enabled" has no effect ...
(Reporter)

Updated

5 years ago
Summary: There is no prompt window on receipt of a return receipt → There is no prompt window on a return receipt request
(Assignee)

Updated

5 years ago
Depends on: 633937
(Assignee)

Comment 2

5 years ago
Confirmed. Tracked it back to bug 633937 which caused this regression.
Severity: normal → major
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
OS: Windows XP → All
Hardware: x86 → All
Version: SeaMonkey 2.25 Branch → Trunk
(Assignee)

Comment 3

5 years ago
Posted patch rr.patchSplinter Review
[Approval Request Comment]
Regression caused by (bug #): bug 633937
User impact if declined: Return Receipt prompt does not appear
Testing completed (on m-c, etc.): verified locally
Risk to taking this patch (and alternatives if risky): low
String changes made by this patch: none
Assignee: nobody → jh
Status: NEW → ASSIGNED
Attachment #8357360 - Flags: review?(neil)
Attachment #8357360 - Flags: approval-comm-beta?
Attachment #8357360 - Flags: approval-comm-aurora?
Comment on attachment 8357360 [details] [diff] [review]
rr.patch

Whoops. I remember finding the B typo when testing the patch to bug 639937; I wonder whether I bothered to retest it corrected or forgot that it needed two corrections. Either way, thanks for finding this.
Attachment #8357360 - Flags: review?(neil) → review+

Updated

5 years ago
Attachment #8357360 - Flags: approval-comm-beta?
Attachment #8357360 - Flags: approval-comm-beta+
Attachment #8357360 - Flags: approval-comm-aurora?
Attachment #8357360 - Flags: approval-comm-aurora+
(Assignee)

Updated

5 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.26

Updated

5 years ago
Duplicate of this bug: 958522
You need to log in before you can comment on or make changes to this bug.