Social API is messed up in Firefox Nightly

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
5 years ago
3 years ago

People

(Reporter: ntim, Unassigned)

Tracking

({regression})

29 Branch
x86_64
Windows 8.1
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Created attachment 8355069 [details]
Screenshot

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0 (Beta/Release)
Build ID: 20131231030203

Steps to reproduce:

Enable Social API.



Actual results:

The buttons are missized, the social api configuration button has been moved down to the sidebar, sidebar has a header.
Even happens in safe mode !!!!
Component: Untriaged → SocialAPI
Other bugs :
- the social geolocation request is moved to the url bar (it was previously a button next to the social config icon)
- Some icons are missing (inspected using Browser Toolbox, it's actually invisible to see, but visible in DOM)
- Facebook social API doesn't have it's toolbar buttons.

The problem of the social API config icon being moved down to the sidebar, is, well you can't open the sidebar without about:config. It was previously in the nav bar.

Comment 2

5 years ago
Shane, any idea what could have caused this?
Flags: needinfo?(mixedpuppy)
Keywords: regression, regressionwindow-wanted
(In reply to :Gijs Kruitbosch from comment #2)
> Shane, any idea what could have caused this?

The old toolbar button is removed, replaced by a header in the sidebar, most of this is by design, there is still some cleanup to happen:

icon sizing is an issue, was looking into it before the break, still have to fix that.

geolocation anchor is a bug, but low priority since no current providers use it (demo provider tests support)

gear icon in the sidebar header needs to be fixed
Flags: needinfo?(mixedpuppy)
(In reply to Shane Caraveo (:mixedpuppy) from comment #3)
> (In reply to :Gijs Kruitbosch from comment #2)
> > Shane, any idea what could have caused this?
> 
> The old toolbar button is removed, replaced by a header in the sidebar, most
> of this is by design, there is still some cleanup to happen:
I honestly prefered the toolbar button on the toolbar, but it's your choice.
In case you really want to move that button, make sure to add a discoverable way to open the sidebar without about:config.

> geolocation anchor is a bug, but low priority since no current providers use
> it (demo provider tests support)
I'm currently using it :
http://clouddesk.altervista.org/about/firefox-addon.html

> gear icon in the sidebar header needs to be fixed
(In reply to Tim Nguyen [:ntim] from comment #4)
> (In reply to Shane Caraveo (:mixedpuppy) from comment #3)
> > (In reply to :Gijs Kruitbosch from comment #2)
> > > Shane, any idea what could have caused this?
> > 
> > The old toolbar button is removed, replaced by a header in the sidebar, most
> > of this is by design, there is still some cleanup to happen:

> I honestly prefered the toolbar button on the toolbar, but it's your choice.

That button limited the user to a single provider at a time.  Using the new status button, the user can have more than one provider at a time in their toolbar, and have control over customizing what providers show up there.

> In case you really want to move that button, make sure to add a discoverable
> way to open the sidebar without about:config.

The sidebar now has the same ui as all other sidebars in firefox.  I'll be looking into improvements around that.
this is a dup of bug 956910,  bug 956956, bug 956870, and bug 935773.  follow those bugs for any updates.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
(In reply to Shane Caraveo (:mixedpuppy) from comment #6)
> this is a dup of bug 956910,  bug 956956, bug 956870, and bug 935773. 
> follow those bugs for any updates.

Where can I find the following bugs, should I fill some of these ? :
- the Facebook Messenger notification icons don't show at all.
- Add a toolbar button to open the sidebar (see attachment 831143 [details])
- Provide an easier way to toggle the sidebar
Flags: needinfo?(mixedpuppy)
(In reply to Tim Nguyen [:ntim] from comment #7)
> (In reply to Shane Caraveo (:mixedpuppy) from comment #6)
> > this is a dup of bug 956910,  bug 956956, bug 956870, and bug 935773. 
> > follow those bugs for any updates.
> 
> Where can I find the following bugs, should I fill some of these ? :
> - the Facebook Messenger notification icons don't show at all.
> - Add a toolbar button to open the sidebar (see attachment 831143 [details])
> - Provide an easier way to toggle the sidebar

These issues are now fixed, and Facebook messenger is discontinued. Removing needinfo.
Flags: needinfo?(mixedpuppy)
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.