Thunderbird-24.2.0 + Mac Mavericks email account setup wizard broken

RESOLVED INCOMPLETE

Status

Thunderbird
Account Manager
RESOLVED INCOMPLETE
4 years ago
3 years ago

People

(Reporter: David Favor, Unassigned)

Tracking

24 Branch
x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9_1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/33.0.1750.5 Safari/537.36

Steps to reproduce:

Try to open a new email account.


Actual results:

Nothing. Checking my imap server logs, Thunderbird never tries to verify account.


Expected results:

Docs show various examples of Edit + Manual Config buttons. These never show up in latest version, so no email accounts can ever be created.

The same buttons should show up in the Mac version Thunderbird as Linux versions.

Also please update this ticket with a workaround for configuring new accounts manually. Meaning, no stupid (judgment) Wizard. Like with Thunderbird-2, which is what I've been using for years, because this problem has existed since Thunderbird-3 and has never been fixed.
(Reporter)

Comment 1

4 years ago
If this is fixed in a development version, send me the download link + I'll test it.

Thanks.
(Reporter)

Comment 2

4 years ago
The workaround is putting Thunderbird in offline mode + setup all accounts + go back to online mode.

Very ugly.

Now probes to imap servers are sent correctly.

Comment 3

4 years ago
Try with new profile... 
*https://support.mozillamessaging.com/en-US/kb/using-multiple-profiles

It works fine in Mavericks 10.9.1

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:24.0) Gecko/20100101 Thunderbird/24.2.0

Other Release of Thunderbird - EarlyBird
*http://www.mozilla.org/en-US/thunderbird/channel/
(Reporter)

Comment 4

4 years ago
I'm running 10.9.1 + no retest or manual config buttons ever show up.

This is done via a clean install, ~/Library/Thunderbird removed first, so no profile issues.
(Reporter)

Comment 5

4 years ago
If it's useful, I can produce a video showing the problem.

Comment 6

3 years ago
Is this seen in version 31?
Flags: needinfo?(david)
Whiteboard: [closeme 2015-01-10]

Updated

3 years ago
Component: Untriaged → Account Manager

Comment 7

3 years ago
Resolved per whiteboard
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(david)
Resolution: --- → INCOMPLETE
Whiteboard: [closeme 2015-01-10]
You need to log in before you can comment on or make changes to this bug.