Closed Bug 955954 Opened 6 years ago Closed 6 years ago

"SIM 1" show up on some places on a one-SIM device

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect)

x86
macOS
defect
Not set

Tracking

(blocking-b2g:1.3+, b2g-v1.3 fixed, b2g-v1.3T fixed, b2g-v1.4 fixed)

RESOLVED FIXED
1.3 C2/1.4 S2(17jan)
blocking-b2g 1.3+
Tracking Status
b2g-v1.3 --- fixed
b2g-v1.3T --- fixed
b2g-v1.4 --- fixed

People

(Reporter: timdream, Assigned: eragonj)

Details

Attachments

(1 file)

For example, in Settings > SIM security, I can see "SIM 1 PIN" even on Peak. This is too confusing for most of us.

Flagging UX for comment and see if this is desirable, even intentional (I hope not).

1.3? because this start to happen on v1.3 branch.
Flags: needinfo?(nhsieh)
Flags: needinfo?(firefoxos-ux-bugzilla)
I think "SIM PIN" is good for single SIM devices.  I don't know why the system shows "SIM 1 PIN",  Maybe we can ask Carrie for DSDS purpose ?
Flags: needinfo?(nhsieh) → needinfo?(cawang)
Hi Tim, 

This is definitely a bug. For DSDS devices, we do have SIM PIN1/ PIN2 to indicate users. This is exclusive for DSDS and we didn't change it on single SIM (no spec no bugs). I'm with you on this. It should be fixed to prevent confusion. Thanks!
Flags: needinfo?(cawang)
Triage: UI breakage.

EJ, could you fix this? Is this a good first bug?
Assignee: nobody → ejchen
blocking-b2g: 1.3? → 1.3+
Flags: needinfo?(ejchen)
ok, took it ! :)
Flags: needinfo?(ejchen)
Attached file patch on github
fixed the problem caused by DSDS design.
Comment on attachment 8356498 [details] [review]
patch on github

Hi Arthur, 

this is a minor UI bug based on DSDS design. I just fixed it and it all look nice on DSDS & single sim device.

Please take a look when you have time ! Thanks :)
Attachment #8356498 - Flags: review?(arthur.chen)
Comment on attachment 8356498 [details] [review]
patch on github

The patch looks good to me. Could you add a unit test for it? Thanks!
Attachment #8356498 - Flags: review?(arthur.chen)
Comment on attachment 8356498 [details] [review]
patch on github

Thanks Arthur, 

just added missing test and it is green now on Travis !

:D
Attachment #8356498 - Flags: review?(arthur.chen)
Comment on attachment 8356498 [details] [review]
patch on github

r=me. Thank you!
Attachment #8356498 - Flags: review?(arthur.chen) → review+
Thanks all, patches were landed on :

gaia/master: 4c64dc55d4d69cca6ca81ccffa1bf72e9a3b3ee6
gaia/v1.3: c0664f9ae1111fe67d9b11009d01ebc01f7bea2c
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Flags: needinfo?(firefoxos-ux-bugzilla)
Target Milestone: --- → 1.3 C2/1.4 S2(17jan)
You need to log in before you can comment on or make changes to this bug.