Closed Bug 955983 Opened 8 years ago Closed 2 years ago

HTML5 Video player doesn't provide dir=rtl to error messages

Categories

(Toolkit :: Video/Audio Controls, defect)

x86
All
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1543828

People

(Reporter: tomer, Unassigned)

References

Details

Attachments

(3 files)

Attached image screenshot
When the HTML5 Video player fail to load, we receive an error message that lacks dir=rtl. While we can workaround it by adding RLE..PDF around the message(s), more elegant solution is required!

Steps to reproduce: (borrowed from bug 955980 ☺)
1. Disable Flash Player from the Addons → Plugins page. 
2. Visit http://www.ynet.co.il/articles/0,7340,L-4464398,00.html

Actual result:
Error message "תסדיר הווידאו או סוג ה־MIME אינו נתמך." ("Video format or MIME type is not supported."). 

Expected result:
Error message "תסדיר הווידאו או סוג ה־MIME אינו נתמך.".
(In reply to Tomer Cohen :tomer from comment #0)
> Expected result:
> Error message "תסדיר הווידאו או סוג ה־MIME אינו נתמך.".
Well, that's weird. Bugzilla have removed the RLE..PDF control characters I placed in the previous comment. Anyway, imagine that the word "תסדיר" is the first word at the right side of the string, and the last word is "נתמך.", while the period is the last and leftmost character in the string.
See Also: → 955980
Assignee: nobody → tomer.moz.bugs
Status: NEW → ASSIGNED
@Tomer
Are you still interested in fixing this? I assume this will need a rebase at this point, and a reviewer, otherwise nobody will really look into it. Since this is not a bug in the Hebrew translation, it should also live in a Code component (moving it to Toolkit::Video/Audio controls, hoping it's the right one).

Potential reviewers
https://hg.mozilla.org/mozilla-central/log/tip/toolkit/content/widgets/videocontrols.css
Component: he / Hebrew → Video/Audio Controls
Product: Mozilla Localizations → Toolkit
See Also: → 1543828

Fixed by bug 1543828.

Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1543828
Assignee: tomer.moz.bugs → nobody
You need to log in before you can comment on or make changes to this bug.