[traceback] URL encoding error in redirect to list events

VERIFIED FIXED

Status

Mozilla Reps
reps.mozilla.org
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: nemo, Assigned: nemo)

Tracking

Details

(Whiteboard: [kb=1227029] )

(Assignee)

Description

4 years ago
Traceback (most recent call last):

  File "/data/www/reps.mozilla.org/remo/vendor/lib/python/django/core/handlers/base.py", line 111, in get_response
    response = callback(request, *callback_args, **callback_kwargs)

  File "/usr/lib64/python2.6/site-packages/newrelic-1.11.0.55/newrelic/api/object_wrapper.py", line 216, in __call__
    self._nr_instance, args, kwargs)

  File "/usr/lib64/python2.6/site-packages/newrelic-1.11.0.55/newrelic/hooks/framework_django.py", line 475, in wrapper
    return wrapped(*args, **kwargs)

  File "/data/www/reps.mozilla.org/remo/vendor/lib/python/django/views/decorators/cache.py", line 89, in _wrapped_view_func
    response = view_func(request, *args, **kwargs)

  File "/data/www/reps.mozilla.org/remo/remo/events/views.py", line 33, in redirect_list_events
    return redirect(urlparams(events_url, hash=extra_path), permanent=True)

  File "/data/www/reps.mozilla.org/remo/vendor/lib/python/django/shortcuts/__init__.py", line 75, in redirect
    return redirect_class(urlresolvers.reverse(to, args=args, kwargs=kwargs))

  File "/usr/lib64/python2.6/site-packages/newrelic-1.11.0.55/newrelic/api/object_wrapper.py", line 216, in __call__
    self._nr_instance, args, kwargs)

  File "/usr/lib64/python2.6/site-packages/newrelic-1.11.0.55/newrelic/hooks/framework_django.py", line 577, in wrapper
    return execute(*args, **kwargs)

  File "/usr/lib64/python2.6/site-packages/newrelic-1.11.0.55/newrelic/hooks/framework_django.py", line 576, in execute
    return wrapped(viewname, *args, **kwargs)

  File "/data/www/reps.mozilla.org/remo/vendor/lib/python/django/core/urlresolvers.py", line 476, in reverse
    return iri_to_uri(resolver._reverse_with_prefix(view, prefix, *args, **kwargs))

  File "/data/www/reps.mozilla.org/remo/vendor/lib/python/django/core/urlresolvers.py", line 360, in _reverse_with_prefix
    lookup_view = get_callable(lookup_view, True)

  File "/usr/lib64/python2.6/site-packages/newrelic-1.11.0.55/newrelic/api/object_wrapper.py", line 216, in __call__
    self._nr_instance, args, kwargs)

  File "/usr/lib64/python2.6/site-packages/newrelic-1.11.0.55/newrelic/api/error_trace.py", line 61, in wrapper
    return wrapped(*args, **kwargs)

  File "/data/www/reps.mozilla.org/remo/vendor/lib/python/django/utils/functional.py", line 27, in wrapper
    result = func(*args)

  File "/data/www/reps.mozilla.org/remo/vendor/lib/python/django/core/urlresolvers.py", line 92, in get_callable
    lookup_view = getattr(import_module(mod_name), func_name)

  File "/data/www/reps.mozilla.org/remo/vendor/lib/python/django/utils/importlib.py", line 35, in import_module
    __import__(name)

UnicodeEncodeError: 'ascii' codec can't encode character u'\xe9' in position 42: ordinal not in range(128)
(Assignee)

Updated

4 years ago
Group: mozilla-reps-admins
(Assignee)

Updated

4 years ago
Whiteboard: [kb=1227029]
(Assignee)

Updated

4 years ago
Summary: [traceback] Error in multiple events ical export → [traceback] URL encoding error in redirect to list events
(Assignee)

Updated

4 years ago
Duplicate of this bug: 956016
(Assignee)

Updated

4 years ago
Assignee: nobody → jgiannelos

Comment 2

4 years ago
Commits pushed to master at https://github.com/mozilla/remo

https://github.com/mozilla/remo/commit/a3544d64ced0d2f8a134c1eac16eb387c1a893c1
[Fix bug 956008] Fix url encoding in events list redirection

https://github.com/mozilla/remo/commit/c8a1ffa80d49414462ad17db6a2b3c51ada535d5
Merge pull request #577 from johngian/956008

[Fix bug 956008] Fix url encoding in events list redirection

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Verify with url /events/period/future/search/estado de méxico./ical/
OS: Linux → All
Hardware: x86_64 → All
This now does not create a 500, but does not return a ical either. I filed bug 956271 to solve this and marking this one as verified / fixed.
Status: RESOLVED → VERIFIED
Version: unspecified → 420
You need to log in before you can comment on or make changes to this bug.