Thunderbird permanently hangs with progress bar at 0, doesn't exit properly

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: schaefer.frank, Unassigned)

Tracking

24 Branch
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:26.0) Gecko/20100101 Firefox/26.0 (Beta/Release)
Build ID: 2013120700

Steps to reproduce:

I started Thunderbird (Linux, x86 32bit)


Actual results:

Very soon after starting Thunderbird 24+, the progress bar at the bottom appears but never changes (stuck at 0).
Ui stays responsive and CPU load doesn't change, but sometimes nothing happens when for example clicking on received messages.
Thunderbird also doesn't exit properly: the Ui disappears but process "thunderbird-bin" doesn't terminate.

It's hard to provide a better description of this bug, because I have no clue what Thunderbird is doing / what the progress bar is supposed to describe.

This bug already occured in older versions, but not very often. Since Thunderbird 24.0, it happens always and makes the program completely unusable.

If there's anything I can do to debug this further, please let me know.


Expected results:

Thunderbird shouldn't hang and exit properly.

Comment 1

5 years ago
Could you check in safemode and new profile and report it back
(Reporter)

Comment 2

5 years ago
(In reply to iamjayakumars from comment #1)
> Could you check in safemode and new profile and report it back

How can I do that and which information do you want exactly ?

Comment 4

5 years ago
> Very soon after starting Thunderbird 24+, the progress bar at the bottom
> appears but never changes (stuck at 0).
> Ui stays responsive and CPU load doesn't change, but sometimes nothing
> happens when for example clicking on received messages.

What precisely is the CPU load?


> Thunderbird also doesn't exit properly: the Ui disappears but process
> "thunderbird-bin" doesn't terminate.

This may be a different issue than your first concern. But we'll lean more per comment 3

> It's hard to provide a better description of this bug, because I have no
> clue what Thunderbird is doing 

see tools | activity manager


> [have no clue] what the progress bar is supposed to describe.
progress bar is totally non-specific - it just means "something" is happening or waiting. but unfortunately it also cannot be totally trusted - there are bugs such that seeing progress bar action doesn't really many anything important is happening.
Keywords: perf
(Reporter)

Comment 5

5 years ago
(In reply to iamjayakumars from comment #1)
> Could you check in safemode and new profile and report it back

It doesn't occur in safemode, but creating a new profile doesn't help.
(Reporter)

Comment 6

5 years ago
(In reply to Wayne Mery (:wsmwk) from comment #4)
> > Very soon after starting Thunderbird 24+, the progress bar at the bottom
> > appears but never changes (stuck at 0).
> > Ui stays responsive and CPU load doesn't change, but sometimes nothing
> > happens when for example clicking on received messages.
> 
> What precisely is the CPU load?

~idle


I will take a closer at the activities when the hanging occurs. I guess it's not always the same one.
(Reporter)

Comment 7

5 years ago
Seems to be a "directory updating" vs. "message indexing" deadlock.

Comment 8

5 years ago
(In reply to schaefer.frank from comment #7)
> Seems to be a "directory updating" vs. "message indexing" deadlock.

Is this your analysis?
Or is this the text that  you see?

We'd prefer to know what is actually on the screen :)
(Reporter)

Comment 9

5 years ago
(In reply to Wayne Mery (:wsmwk) from comment #8)
> (In reply to schaefer.frank from comment #7)
> > Seems to be a "directory updating" vs. "message indexing" deadlock.
> 
> Is this your analysis?
> Or is this the text that  you see?
What I see is one directory updating activity which is stuck at message x of y and a message indexing activity with an alternating progress bar (no progress displayed). No change for more than 30 minutes.
The messages in the folder aren't very large (account for mailing lists only).

> We'd prefer to know what is actually on the screen :)
Ok, I'll stop drawing conclusions. ;)
(Reporter)

Comment 10

5 years ago
Update:

On Monday I decided to keep the computer on the whole day to see what happens.
When I checked the first time after nearly 3 hours, the directory updating activity had moved on from message 102/237 to 105/237. The message indexing activity was still showing no progress (alternating progress bar) but the CPU usage of Thunderbird was increased to ~10% at that time.
When I came back in the evening, both activities finally were finished.
So it's not really a kind of deadlock, the activities just temporarily hang or are just extremely slow.

Since the message indexing is finished, the hanging still occurs, but now I can see that
- it happens with all kinds of activities
- sometimes the hanging occurs when an activity has already reached 100%
- sometimes the hanging seems to occur between two activities (*)

I really hate this kind of indistinct bugs !
If I had to create this bug report today, I would have called it "Extremely slow / temporary hanging activities causing Thunderbird to not exit properly".


(*): steps:
1: an activity get's finished => no active activities anymore on the list
2: the main window status bar is still there (and so far it has always been alternating)
3: after a while a new activity appears on the list
(Reporter)

Comment 11

5 years ago
(In reply to schaefer.frank from comment #10)
> If I had to create this bug report today, I would have called it "Extremely
> slow / temporary hanging activities causing Thunderbird to not exit
> properly".

Better scratch the last part. I causes several problems and program exit is just just one of them.

Updated

5 years ago
Keywords: perf
(Reporter)

Comment 12

4 years ago
Doesn't happen anymore an a fresh system, so I think this bug can be closed.
(Reporter)

Updated

4 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.