Same webpage renders differently in two different homescreen bookmarks

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: zcampbell, Unassigned)

Tracking

({regression})

29 Branch
Other
Gonk (Firefox OS)
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
STR:
1. Using e.me, install the apps "BBC" and "BBC Sport" using those search strings on everything.me. Install them onto the homescreen by long press

2. Load "BBC" app and note the background colour is white
3. Load "BBC Sport", then click [BBC] icon in the top left corner. This will navigate to the same page as viewed in step 2.

4. The page loaded in Step 3 will hvae a dark grey background instead of white.


Device: hamachi
Gecko  http://hg.mozilla.org/mozilla-central/rev/c8d5a871ae32
Gaia  5de94a2be6ab8d33434294d70c1de330f55d8f2d
BuildID 20140101040201
Version 29.0a1
(Reporter)

Comment 1

5 years ago
Created attachment 8355204 [details]
step 2 screenshot
(Reporter)

Comment 2

5 years ago
Created attachment 8355205 [details]
step 4 screenshot
We need to isolate if this is a TE issue or not.

Can we check if this reproduces on 1.1?
Component: Gaia::Homescreen → General
Keywords: qawanted

Comment 4

5 years ago
The issue does not reproduce on the latest 1.1 build. The BBC webpage renders the same for the BBC app and the BBC Sports page.

Device: Buri 1.1 MOZ
BuildID: 20140102041202
Gaia: 6ff3a607f873320d00cb036fa76117f6fadd010f
Gecko: bdac595a4e46
Version: 18.0
RIL Version: 01.02.00.019.102
Firmware Version: V1.2_20131115
Keywords: qawanted
QA Contact: nkhristoforov
Okay - that implies this is definitely a regression in gecko.

Does this reproduce on 1.2, 1.3, or 1.4?
Keywords: qawanted, regression

Comment 6

5 years ago
The bug only reproduces on the latest 1.4 build. The latest 1.2 and 1.3 builds rendered the webpage correctly for both bookmarks.

Device: Buri 1.4 MOZ
BuildID: 20140102040201
Gaia: 67a82f88da231969efa4d22df9fb946abf2cf4df
Gecko: 540d85f60c57
Version: 29.0a1
Keywords: qawanted

Updated

5 years ago
blocking-b2g: --- → 1.4?
Component: General → Graphics
Keywords: regressionwindow-wanted
Product: Firefox OS → Core
Version: unspecified → 29 Branch

Comment 7

5 years ago
The regression window for this bug is 12-10 to 12-11.

Last Working Build:
Device: Buri 1.4 MOZ
BuildID: 20131210040206
Gaia: c952e2756c03eceb4de6a3eba15651741a62f9e8
Gecko: df82be9d89a5
Version: 29.0a1

First Broken Build:
Device: Buri 1.4 MOZ
BuildID: 20131211040203
Gaia: 6415b8b44068596404c10365394544e94edd5ce5
Gecko: 12ea03a70243
Version: 29.0a1
Keywords: regressionwindow-wanted
Can we retest on the latest 1.4? Lots of things have probably changed on trunk, so let's re-verify if this still happens.
Keywords: qawanted
Currently blocked from checking by https://bugzilla.mozilla.org/show_bug.cgi?id=971268. Will re-verify when able.
QA Contact: nkhristoforov → pbylenga
This doesn't happen on v1.4 anymore due to the impact of the patch of bug 971268.  The bookmark function remembers BBC Sport was the access point, so after navigating to BBC within BBC Sport web.app and tapping on Bookmark, it'll bookmark BBC Sport regardless of the area the User has navigated to.

Another example to emphasize the new flow.

1. Search for 'Google' in Rocketbar
2. After launch search for 'Yahoo' in Google
3. Navigate to Yahoo and tap bookmark

Actual results: Bookmark is for Google

Furthermore, the user is unable to ever bookmark 'Yahoo' when accessing browser functionality via the web.app google.

Comment 13 of Bug 971268 implies the fix is not the final implementation of the feature, if what is seen above needs to be recorded I can file a new bug to track it.

v1.4 Environmental Variables:
Device: Buri v1.4 MOZ
BuildID: 20140219040204
Gaia: ac06cfbd2baf6494ffbb668cc599e3892cd5e17b
Gecko: bf0e76f2a7d4
Version: 30.0a1
Firmware Version: v1.2-device.cfg
Keywords: qawanted
Rocketbar is going to be disabled soon, so you should be able to workaround this for 1.4. The other option you could do is pull Gaia directly and flash a custom master build with ROCKETBAR=0. Leaving qawanted for that testing.
Keywords: qawanted
Why is this graphics and does it need 1.4?
Doesn't look like this reproduces anymore - closing as a wfm
Status: NEW → RESOLVED
blocking-b2g: 1.4? → ---
Last Resolved: 5 years ago
Keywords: qawanted
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.