media/mtransport/test/ fails to build after nullptr conversion

RESOLVED DUPLICATE of bug 938092

Status

()

Core
General
RESOLVED DUPLICATE of bug 938092
4 years ago
4 years ago

People

(Reporter: gcp, Unassigned)

Tracking

Trunk
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
Building with gcc 4.5 is broken:

0:09.71 /home/morbo/hg/mozilla-central/media/mtransport/test/rlogringbuffer_unittest.cpp: In member function ‘virtual void RLogRingBufferTest_TestGetFree_Test::TestBody()’:
 0:09.71 Warning: with T1 = long int, T2 = mozilla::RLogRingBuffer* in /home/morbo/hg/mozilla-central/media/mtransport/test/rlogringbuffer_unittest.cpp: passing NULL to non-pointer argument 3 of ‘testing::AssertionResult testing::internal::CmpHelperNE(const char*, const char*, const T1&, const T2&)
 0:09.71 /home/morbo/hg/mozilla-central/media/mtransport/test/rlogringbuffer_unittest.cpp:54:151: warning: passing NULL to non-pointer argument 3 of ‘testing::AssertionResult testing::internal::CmpHelperNE(const char*, const char*, const T1&, const T2&) [with T1 = long int, T2 = mozilla::RLogRingBuffer*]’
 0:09.71 Warning: with T1 = long int, T2 = mozilla::RLogRingBuffer* in /home/morbo/hg/mozilla-central/media/mtransport/test/rlogringbuffer_unittest.cpp: passing NULL to non-pointer argument 3 of ‘testing::AssertionResult testing::internal::CmpHelperNE(const char*, const char*, const T1&, const T2&)
 0:09.71 /home/morbo/hg/mozilla-central/media/mtransport/test/rlogringbuffer_unittest.cpp:54:151: warning: passing NULL to non-pointer argument 3 of ‘testing::AssertionResult testing::internal::CmpHelperNE(const char*, const char*, const T1&, const T2&) [with T1 = long int, T2 = mozilla::RLogRingBuffer*]’
 0:09.71 In file included from /home/morbo/hg/mozilla-central/media/mtransport/test/rlogringbuffer_unittest.cpp:17:0:
 0:09.71 /home/morbo/hg/mozilla-central/media/webrtc/trunk/testing/gtest/include/gtest/gtest.h: In function ‘testing::AssertionResult testing::internal::CmpHelperNE(const char*, const char*, const T1&, const T2&) [with T1 = long int, T2 = mozilla::RLogRingBuffer*]’:
 0:09.71 /home/morbo/hg/mozilla-central/media/mtransport/test/rlogringbuffer_unittest.cpp:54:151:   instantiated from here
 0:09.71 /home/morbo/hg/mozilla-central/media/webrtc/trunk/testing/gtest/include/gtest/gtest.h:1532:136: error: ISO C++ forbids comparison between pointer and integer

That's:
  ASSERT_NE(nullptr, instance);

Same problem in: media/mtransport/test/buffered_stun_socket_unittest.cpp

EXPECT_NE(nullptr, write_buffer_.get());

This appears to be the kind of failure that NullPtr.h can't fix.
(Reporter)

Updated

4 years ago
Blocks: 784739
Dupe of Bug 938092 looks like
(Reporter)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 938092
You need to log in before you can comment on or make changes to this bug.