If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Crash in BluetoothA2dpManager::OnConnect when turning BT on/off in background

RESOLVED WORKSFORME

Status

Firefox OS
Bluetooth
--
blocker
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: Greg Grisco, Assigned: btian)

Tracking

(Blocks: 1 bug, {crash, regression})

unspecified
1.3 C2/1.4 S2(17jan)
ARM
Gonk (Firefox OS)
crash, regression

Firefox Tracking Flags

(blocking-b2g:1.3+, b2g-v1.3 affected)

Details

(Whiteboard: [CR 593172][b2g-crash], crash signature)

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8355257 [details]
15088de1-dcf6-e181-0836505b-1c86030a.txt

Steps :

1.BT on/off script executes simultaneously in the background.
2.Connect to any AP.
3.Browse the web on the DUT.
4.Try to make A2DP connection.

Crash with signature:  
[@ mozilla::dom::bluetooth::BluetoothProfileController::OnConnect(nsAString_internal const&) | mozilla::dom::bluetooth::BluetoothA2dpManager::OnConnect(nsAString_internal const&) | ReplyErrorToProfileManager::Run() | nsThread::ProcessNextEvent(bool, bool*) ]
(Reporter)

Comment 1

4 years ago
Created attachment 8355258 [details]
EXTRA file attachment

Updated

4 years ago
Keywords: crash, regression
Whiteboard: [CR 593172] → [CR 593172][b2g-crash]

Updated

4 years ago
Crash Signature: [@ mozilla::dom::bluetooth::BluetoothProfileController::OnConnect(nsAString_internal const&)]
Eric,

Can you please take a look?
Flags: needinfo?(echou)
1.3+ as QC needs this issue fixed by 1/10/14.
blocking-b2g: 1.3? → 1.3+
Assignee: nobody → btian
Target Milestone: --- → 1.3 C2/1.4 S2(17jan)
(Reporter)

Comment 4

4 years ago
We haven't seen this crash for a couple of weeks, so closing for now.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
Clear ni since this has been closed.
Flags: needinfo?(echou)
You need to log in before you can comment on or make changes to this bug.