[FEATURE] routeEvent() method not implemented.

VERIFIED FIXED in M14

Status

()

P3
normal
VERIFIED FIXED
20 years ago
19 years ago

People

(Reporter: desale, Assigned: joki)

Tracking

({testcase})

Trunk
x86
All
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [TESTCASE] window.routeEvent() must be implemented)

Attachments

(1 attachment)

(Reporter)

Description

20 years ago
Method window.routeEvent() is returning undefined.

PRODUCT: Seamonkey [Apprunner/Viewer]
BUILD: 07-08-08.
OS: Win95, WinNT, Win98, MacOS.

STEPS TO REPRODUCE:
1] Please copy code I'm providing. Save as HTML file.
2] Open this HTML file in Apprunner as well as Viewer.
3] You'll see the return value of window.routeEvent() getting printed on
screen.

NOTE: In actual code [testcase] the method is used without parantheses in order
to know what it is exactly.

EXPECTED RESULTS:
window.routeEvent() = function routeEvent() { [native code] }

ACTUAL RESULTS:
window.routeEvent() = undefined

CODE:

<html>
<head>
<title>Test Page</title>
</head>
<body>
<form name="workform">
<SCRIPT LANGUAGE="JavaScript">
document.writeln("window.routeEvent() = ");
document.writeln(window.routeEvent);
</SCRIPT>
</form>
</body>
</html>

END OF CODE

Updated

20 years ago
Summary: window.routeEvent() is returning undefined. → window.routeEvent() is returning undefined.
Whiteboard: [TESTCASE] window.routeEvent() must be implemented

Comment 1

20 years ago
Created attachment 805 [details]
desale's test case as attachment for convenience

Comment 2

20 years ago
next one. updated status to "[TESTCASE] ..." standard
(Reporter)

Updated

19 years ago
Summary: window.routeEvent() is returning undefined. → routeEvent() method not implemented.
(Reporter)

Comment 3

19 years ago
Same thing is happening with document.routeEvent(), so it means this method not
implemented for any object.
Changing Summary.
Sorry, Tom.  Vidur says you probably have dups of these bugs already, so it
shouldn't hurt _too_ much.
(Assignee)

Updated

19 years ago
Target Milestone: M11 → M12
(Assignee)

Comment 6

19 years ago
Moving multiple bugs to m12

Comment 7

19 years ago
Moving to m13 because Joki seems to be distracted.
Summary: routeEvent() method not implemented. → [FEATURE] routeEvent() method not implemented.
Target Milestone: M13 → M14
Moving M14.
(Assignee)

Updated

19 years ago
Target Milestone: M14 → M13
(Assignee)

Comment 9

19 years ago
Moving 4.x event system features back to M13
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M13 → M14
(Assignee)

Comment 10

19 years ago
Well the 4.x event stuff is done but its untested.  Given that I had to make
several changes to general event handling I think I'll take the conservative
road this time and save this till the tree opens for M14.
Bulk moving [testcase] code to new testcase keyword. Sorry for the spam!
Keywords: testcase
(Assignee)

Comment 12

19 years ago
This will never work exactly the same way as it did in 4x but I think it will 
suffice.  Marking fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Reporter)

Comment 13

19 years ago
Verified with 2000-02-17-08.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.