[UITests] Travis Intermittent: test_system_message.py test_system_message.TestSystemMessages.test_app_launched_by_system_message

RESOLVED FIXED

Status

P1
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: kgrandon, Assigned: Bebe)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

46 bytes, text/x-github-pull-request
viorela
: review+
bsilverberg
: review+
AlinT
: review+
Details | Review | Splinter Review
(Reporter)

Description

5 years ago
test_system_message.py test_system_message.TestSystemMessages.test_app_launched_by_system_message


test_app_launched_by_system_message (test_system_message.TestSystemMessages) ... ERROR

======================================================================
ERROR: None
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/usr/local/lib/python2.7/dist-packages/marionette_client-0.7.1-py2.7.egg/marionette/marionette_test.py", line 127, in run
    self.setUp()
  File "/home/travis/build/mozilla-b2g/gaia/tests/python/gaia-ui-tests/gaiatest/gaia_test.py", line 834, in setUp
    self.device.start_b2g()
  File "/home/travis/build/mozilla-b2g/gaia/tests/python/gaia-ui-tests/gaiatest/gaia_test.py", line 742, in start_b2g
    self.marionette.start_session()
  File "/usr/local/lib/python2.7/dist-packages/marionette_client-0.7.1-py2.7.egg/marionette/marionette.py", line 681, in start_session
    self.session = self._send_message('newSession', 'value')
  File "/usr/local/lib/python2.7/dist-packages/marionette_client-0.7.1-py2.7.egg/marionette/marionette.py", line 562, in _send_message
    response = self.client.send(message)
  File "/usr/local/lib/python2.7/dist-packages/marionette_client-0.7.1-py2.7.egg/marionette/client.py", line 85, in send
    self.connect()
  File "/usr/local/lib/python2.7/dist-packages/marionette_client-0.7.1-py2.7.egg/marionette/client.py", line 67, in connect
    self.sock.connect((self.addr, self.port))
  File "/usr/lib/python2.7/socket.py", line 224, in meth
    return getattr(self._sock,name)(*args)
TEST-UNEXPECTED-FAIL | test_system_message.py test_system_message.TestSystemMessages.test_app_launched_by_system_message | error: [Errno 111] Connection refused
----------------------------------------------------------------------
Ran 1 test in 60.914s

FAILED (errors=1)

Comment 2

5 years ago
This is an interesting one; it is failing in the setUp before it even gets to the test.

It's possible the previous test is leaving b2g in a bad state.

Comment 3

5 years ago
I cannot reproduce this, I run all the tests from system on desktop repeating over 30 times, since Zac suggested that it's possible for a previous test to leave b2g in a bad state.
I don't really know if my methods were correct in investigating this. Do you have other suggestions on how to try to replicate this?
(Reporter)

Comment 4

5 years ago
I saw this on Travis only twice in ~200 runs. I believe it was the only failure each time. Unfortunately I don't have much more information than that.
(Assignee)

Updated

5 years ago
Assignee: nobody → florin.strugariu
Status: NEW → ASSIGNED
(Assignee)

Comment 5

5 years ago
Ran this a bunch of times locally and it works... Let's see what Travis thinks 


REPEAT 25
-------
test_app_launched_by_system_message (test_system_message.TestSystemMessages) ... ok

----------------------------------------------------------------------
Ran 1 test in 12.364s

OK

SUMMARY
-------
passed: 26
failed: 0
todo: 0
(Assignee)

Comment 6

5 years ago
Let's enable this and see how it goes...

Comment 7

5 years ago
Bebe, before you re-enable this can you do a Travis run that repeats the test 200 times?

I think this bug might be improved by bug 956780.
(Assignee)

Comment 8

5 years ago
Zac https://travis-ci.org/mozilla-b2g/gaia/jobs/16868280 
Let's see how it looks like :D
(Assignee)

Comment 9

5 years ago
SUMMARY
-------
passed: 201
failed: 0
todo: 0

Looks like we are good :D
(Assignee)

Comment 10

5 years ago
Created attachment 8359265 [details] [review]
pull request
Attachment #8359265 - Flags: review?(zcampbell)
Attachment #8359265 - Flags: review?(viorela.ioia)
Attachment #8359265 - Flags: review?(trifandreialin)
Attachment #8359265 - Flags: review?(bob.silverberg)
Comment on attachment 8359265 [details] [review]
pull request

r+
Attachment #8359265 - Flags: review?(trifandreialin) → review+
Attachment #8359265 - Flags: review?(viorela.ioia) → review+
Comment on attachment 8359265 [details] [review]
pull request

Landed in https://github.com/mozilla-b2g/gaia/commit/4eb1a3ba2b825e210a25f14faacc11c7a7f4e861. If it pops up as an intermittent again we'll have to take another look.
Attachment #8359265 - Flags: review?(zcampbell)
Attachment #8359265 - Flags: review?(bob.silverberg)
Attachment #8359265 - Flags: review+
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.