[Tarako][B2g]RIL Worker[0]: Parcel handling threw TypeError: onerror is not a function

RESOLVED DUPLICATE of bug 968550

Status

Firefox OS
RIL
RESOLVED DUPLICATE of bug 968550
5 years ago
4 years ago

People

(Reporter: Ming, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
1732 12-30 10:18:09.700 I/Gecko   (   82): RIL Worker[0]: ICC I/O Error code null EF id = 6fcd command = c0(6a/82)
1733 12-30 10:18:09.700 I/Gecko   (   82): RIL Worker[0]: Parcel handling threw TypeError: onerror is not a function
1734 12-30 10:18:09.700 I/Gecko   (   82): processICCIOError@resource://gre/modules/ril_worker.js:11320
1735 12-30 10:18:09.700 I/Gecko   (   82): REQUEST_SIM_IO@resource://gre/modules/ril_worker.js:5222
1736 12-30 10:18:09.700 I/Gecko   (   82): handleParcel@resource://gre/modules/ril_worker.js:4854
1737 12-30 10:18:09.700 I/Gecko   (   82): processParcel@resource://gre/modules/ril_worker.js:148
1738 12-30 10:18:09.700 I/Gecko   (   82): processIncoming@blob:c935a794-ce9a-48bf-971a-e75f4610e15d:536
1739 12-30 10:18:09.700 I/Gecko   (   82): onRILMessage@resource://gre/modules/ril_worker.js:13647

Comment 1

4 years ago
are we still able to reproduce this bug?

Comment 2

4 years ago
Shawn, it is simillar with what you done before? can you please help this? Thanks.
Flags: needinfo?(sku)

Comment 3

4 years ago
Hi Ken:
 I did not handle this case before. I will try to check this later.
Thanks!!
Shawn
Flags: needinfo?(sku)

Comment 4

4 years ago
This issue should be fixed already.


commit f072fdfae872573a88650ea1fe25dfdc883d85e1
Author: Fabien Cazenave (kaze@mozilla.com) <Fabien Cazenave (kaze@mozilla.com)>
Date:   Thu Feb 27 15:25:17 2014 +0800

    Bug 968550 - onerror is undefined in processICCIOError. r=yoshi, a=bajaj

Updated

4 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 968550

Comment 6

4 years ago
(In reply to shawn ku [:sku] from comment #3)
> Hi Ken:
>  I did not handle this case before. I will try to check this later.
> Thanks!!
> Shawn
Thanks and sorry for wrong memory.
You need to log in before you can comment on or make changes to this bug.