Closed Bug 956209 Opened 6 years ago Closed 6 years ago

text wrong clipping (like in textarea box)

Categories

(Core :: Graphics, defect)

29 Branch
x86
Windows XP
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 953334

People

(Reporter: alex, Unassigned)

References

()

Details

(Keywords: regression)

Attachments

(1 file)

Attached image text_clipping_bug.png
text wrong clipping (like in textarea box)

Few months ago I've seen that some text in the page goes clipped wrong by the borders of text-holding element.
I thought that someone already filed this bug, but I can't find that.

Please see attached screenshot.

You can create textarea element like this

data:text/html,<textarea>

add some text and resize textarea to hit middle of text line. Then somehow click or select text and click outside textarea - part of text will not be clipped by textarea and appears outside.

But this is not a textarea bug, I've seen wrong clipped text that been absolute positioned inside a container which have overflow:hidden.
This bug exist in nightly (29) with fresh profile. But can't reproducible in stable Firefox 26.
WFM on:
Mozilla/5.0 (X11; Linux i686; rv:29.0) Gecko/20100101 Firefox/29.0

Does this issue occur all the time to you or is it intermittent? It might also be OS-dependent.
Flags: needinfo?(alex)
On the sessionrestore page it happens every time, in the textarea - it intermittent (it needs few times to select text). 
I don't have any other OS to check. If you can check it on Windows XP please do so.

UA: Mozilla/5.0 (Windows NT 5.1; rv:29.0) Gecko/20100101 Firefox/29.0
Flags: needinfo?(alex)
Please load about:support and post the info in the Graphics section from that page.
Flags: needinfo?(alex)
WFM on Windows XP too (SP3 x86):
Mozilla/5.0 (Windows NT 5.1; rv:29.0) Gecko/20100101 Firefox/29.0
Graphics
Adapter Description	AMD RADEON HD 6450
Adapter Drivers	ati2dvag
Adapter RAM	Unknown
Device ID	0x6779
DirectWrite Enabled	true (0.0.0.0)
Driver Date	11-29-2012
Driver Version	9.0.100.2000
GPU #2 Active	false
GPU Accelerated Windows	2/2 Direct3D 9
Vendor ID	0x1002
WebGL Renderer	Google Inc. -- ANGLE (AMD RADEON HD 6450 Direct3D9 vs_3_0 ps_3_0)
windowLayerManagerRemote	false
AzureCanvasBackend	skia
AzureContentBackend	cairo
AzureFallbackCanvasBackend	cairo
AzureSkiaAccelerated	0
Flags: needinfo?(alex)
Does the problem also occur if you disable hardware acceleration?
(There's a checkbox in Preferences->Advanced.  Restart Firefox after changing it.)
Flags: needinfo?(alex)
Yes, that actually helps. I cant reproduce this on <textarea>, and sessionrestore box looks good now.
So, the suspect is direct2d text rendering?
Flags: needinfo?(alex)
Status: UNCONFIRMED → NEW
Component: General → Graphics
Ever confirmed: true
Keywords: regression
Product: Firefox → Core
Bug 953334 did fix some clipping related bug, could you test again in a Nightly dated
2014-01-10 or later (when they become available)?
Flags: needinfo?(alex)
It looks like fixed with this update. Sessionrestore screen looks good, and i cant reproduce textarea bug now. Thanks Mats. You can set this bug as duplicate or dependent of Bug 953334 and so fixed. I don't know the correct way.

Can anyone else test it? Just to make sure.
Flags: needinfo?(alex)
Thanks for the report and for testing!
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 953334
You need to log in before you can comment on or make changes to this bug.