Closed Bug 956265 Opened 7 years ago Closed 7 years ago

[Flatfish][Settings] Sluggish UI when "Enable hardware composer" is set (and is set by default)

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 947504
1.3 C3/1.4 S3(31jan)

People

(Reporter: echang, Unassigned)

References

Details

(Keywords: perf, Whiteboard: [c=handeye p= s=2014.01.31 u=flatfish] [Flatfish only][developer+])

Attachments

(1 file)

Gaia      3a94cb833089e750614dfee5272937b358bc514b    
Gecko     c080356941f5b69ca7632332823a18aa8fdff004    
BuildID   20140103064521    
Version   29.0a1            
ro.build.version.incremental=20140103    
ro.build.date=Fri Jan  3 06:53:02 CST 2014 

1. "Settings" -> "Device information"  -> "More Information" -> "Developer" -> "Enable hardware composer" is SET by default
2. UI is sluggish and not very responsive. 
3. Works okay after clearing this checkbox
4. Works okay with Buri
Flags: needinfo?(vlin)
hi Vincent,

enable HW composer drag down largely Flatfish's performance. could you please double check and see if this is enable during gfx workweek? and reconsider to disable it for Flatfish?
(In reply to Francis Lee [:frlee] from comment #2)
> hi Vincent,
> 
> enable HW composer drag down largely Flatfish's performance. could you
> please double check and see if this is enable during gfx workweek? and
> reconsider to disable it for Flatfish?

I would suggest to disable it for FlatFish first because this feature is not fully tested on this platform.
And there will be no performance issue on FlatFish without HWComposer.
Flags: needinfo?(vlin)
Just found out the root cause.

The hard-coded flag assignment(mRBSwapSupport = true) here makes FlatFish abnormal. (which assumes HAL already supports R/B swap.)
https://mxr.mozilla.org/mozilla-central/source/widget/gonk/HwcComposer2D.cpp#103

In fact, even HWComposer is enabled in general, we expected composition is supposed to fallback to GPU on FlatFish. But hard-coded flag(mRBSwapSupport) makes composition go into HWComposer unexpectedly.

Before having a better solution in Gonk to deal with the compatibility issue, we rely on Bug 956193 to disable "layers.composer2d.enabled" preference in Gaia.
Flags: needinfo?(mwu)
Flags: needinfo?(dwilson)
Keywords: perf
Whiteboard: [Flatfish only][developer+] → [c=handeye p= s= u=flatfish] [Flatfish only][developer+]
Hi vlin,

If you don't support rb swap you might as well disable HWC entirely.

HWC used to be toggled by a gecko pref and now is toggled by gaia setting. It has always been enabled by default but my guess is that flatfish had the gecko pref set to disable it, which was made obsolete once it switched to a gaia setting.
Flags: needinfo?(dwilson)
The RB swap default should probably be based on whether we have colorfill, since they tend to go together on ICS where we can't query HWC features.
Flags: needinfo?(mwu)
kanru made a good point in bug 958460 that hwc was not really supposed to be "enabled by default" but "enabled by default as long as colorfill is present". I'll follow up in bug 958460 with a patch.

This will likely disable HWC on flatfish by default. From there on it's up to you guys to decide if you care about HWC on flatfish.
Blocks: 956193
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 947504
Whiteboard: [c=handeye p= s= u=flatfish] [Flatfish only][developer+] → [c=handeye p= s=2014.01.31 u=flatfish] [Flatfish only][developer+]
Target Milestone: --- → 1.3 C3/1.4 S3(31jan)
You need to log in before you can comment on or make changes to this bug.