Firefox window should act like EVERY OTHER WINDOW in my OS

RESOLVED DUPLICATE of bug 574973

Status

()

RESOLVED DUPLICATE of bug 574973
5 years ago
5 years ago

People

(Reporter: wb.stow, Unassigned)

Tracking

26 Branch
x86_64
Windows 8
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/30.0.1599.101 Safari/537.36

Steps to reproduce:

Just close the window when I double click the upper left corner, mmmkay?


Actual results:

Nothing


Expected results:

The window should close. Like EVERY OTHER WINDOW in my OS.

Comment 1

5 years ago
This behavior is caused by small icon in standard title bar by Windows, but Firefox does not display the icon, so no.
(Reporter)

Comment 2

5 years ago
Chrome manages to behave properly without displaying a small icon in the standard title bar.

Tons of people have complained about this all over the net. Firefox has broken a very basic user interaction and it should be fixed.

Please figure it out. Thanks.
(Reporter)

Comment 3

5 years ago
Furthermore, this Firefox addon fixes the problem so obviously it's an easily attainable feat.

https://addons.mozilla.org/en-US/firefox/addon/restartless-app-button-quit/

Why do I have to go hunt down an addon to make Firefox act like every other program on my OS? Just fix it please.

Comment 4

5 years ago
sorry for marking, but please first look this.

suggest making a new bug for Firefox's new Australis to reach this point.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 574973
You need to log in before you can comment on or make changes to this bug.