Closed Bug 956381 Opened 9 years ago Closed 9 years ago

IARC screen is blank due to ReferenceError: hideshowAccordions is not defined

Categories

(Marketplace Graveyard :: Developer Pages, defect, P1)

defect

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: krupa.mozbugs, Assigned: dkassack)

References

()

Details

Attachments

(1 file)

Attached image screenshot
Aurora 28.0a2 (2014-01-03)

steps to reproduce:
1. Upload an app on the latest Aurora
2. After submission, click Continue to set up Content ratings
3. Click the button to get the IARC certificate

expected behavior:
IARC questionnaire loads


observed behavior:
IARC screens loads but is blank. Console shows the following JS error


ReferenceError: hideshowAccordions is not defined 
Submission.aspx:6167
Note: works fine on Firefox Stable 27.0 on -dev.
Do we need to look into this?
It is worth looking into. The IARC form page may be broken when the next version of Firefox releases.
I see this on Firefox 26 as well. Definitely a P1

https://www.dropbox.com/s/lm5fjyh19b56b75/Screenshot%202014-01-03%2012.32.20.png

This is blocking me from testing this feature.
Priority: -- → P1
Thanks for the reply David.  Sounds like this is blocking further testing
Assignee: nobody → dkassack
I tried the latest version of FF (26) and Aurora (28) and didn't get the error in either.  

How are you getting to the page?  If using the above URL (https://www.globalratings.org/iarcDEMORating/Submission.aspx) without the correct form parameters, a message appears saying that the user has to come from a storefront, then a blank Submission form is shown.  Could this be what's happening?  

The site must be accessed via the FF storefront or directly using our test page: https://www.globalratings.org/iarcDEMOClient/bridge.aspx

- Simon/ESRB
I am visiting the ESRB site from Marketplace developer hub.

STR:
1. Upload an app to marketplace devhub
2. Click Continue after submission to set up Content ratings


I made a screencast: http://screencast.com/t/lSSwAdwXT
I'm not certain if this has been resolved because we see that the submission was eventually processed, but from our side (ESRB/IARC), we have been unable to duplicate this error. Please let me know if this requires additional follow-up.
The page loads with content now. Closing this as WFM. I'll reopen if I can reproduce it.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.