Closed Bug 956419 Opened 6 years ago Closed 6 years ago

JavaScript error: nfc_handover.js, line 404: this.bluetooth is undefined

Categories

(Firefox OS Graveyard :: NFC, defect)

x86
macOS
defect
Not set

Tracking

(b2g-v1.3 affected)

RESOLVED DUPLICATE of bug 963556
Tracking Status
b2g-v1.3 --- affected

People

(Reporter: gwagner, Unassigned)

References

Details

Seen during gaia unit tests. I don't think this causes the suite to fail but we should fix it.

https://tbpl.mozilla.org/php/getParsedLog.php?id=32530548&tree=B2g-Inbound&full=1
(In reply to Gregor Wagner [:gwagner] from comment #0)
> Seen during gaia unit tests. I don't think this causes the suite to fail but
> we should fix it.
> 
> https://tbpl.mozilla.org/php/getParsedLog.php?id=32530548&tree=B2g-
> Inbound&full=1

Greg: would you mind checking the version you are using? The latest pull request from has the file nfc_handover.js renamed to nfc_handover_manager.js. It seems you were testing an old version.
(In reply to arno from comment #1)
> (In reply to Gregor Wagner [:gwagner] from comment #0)
> > Seen during gaia unit tests. I don't think this causes the suite to fail but
> > we should fix it.
> > 
> > https://tbpl.mozilla.org/php/getParsedLog.php?id=32530548&tree=B2g-
> > Inbound&full=1
> 
> Greg: would you mind checking the version you are using? The latest pull
> request from has the file nfc_handover.js renamed to
> nfc_handover_manager.js. It seems you were testing an old version.

This happens when we run gaia unit tests on b2g-inbound. This would mean we are not using trunk to test? Seems strange.
Evelyn: do you know what happened here?
Flags: needinfo?(ehung)
(In reply to Gregor Wagner [:gwagner] from comment #2)
> (In reply to arno from comment #1)
> > (In reply to Gregor Wagner [:gwagner] from comment #0)
> > > Seen during gaia unit tests. I don't think this causes the suite to fail but
> > > we should fix it.
> > > 
> > > https://tbpl.mozilla.org/php/getParsedLog.php?id=32530548&tree=B2g-
> > > Inbound&full=1
> > 
> > Greg: would you mind checking the version you are using? The latest pull
> > request from has the file nfc_handover.js renamed to
> > nfc_handover_manager.js. It seems you were testing an old version.
> 
> This happens when we run gaia unit tests on b2g-inbound. This would mean we
> are not using trunk to test? Seems strange.

b2g-inbound runs tests on checked-in gecko/gaia code, so the JS error happens on nfc_handover.js should be addressed in your pull request (on the renamed nfc_handover_manager.js).
Flags: needinfo?(ehung)
(In reply to Evelyn Hung [:evelyn] from comment #4)
> b2g-inbound runs tests on checked-in gecko/gaia code, so the JS error
> happens on nfc_handover.js should be addressed in your pull request (on the
> renamed nfc_handover_manager.js).

if I understand you correctly, you haven't imported my latest pull request yet, so, this bug report should be closed because it is using a deprecated version of the Handover Manager.
This affects B2G Desktop 1.3 mozilla-aurora and 1.4 mozilla-central (master).

Tested with:

http://ftp.mozilla.org/pub/mozilla.org/b2g/nightly/2014/01/2014-01-10-04-02-06-mozilla-central/b2g-29.0a1.multi.mac64.dmg

(One can see this on startup)
can we close this bug?
Flags: needinfo?(anygregor)
Blocks: b2g-NFC-2.0
nfc_handover.js has been removed in Bug 963556
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(anygregor)
Resolution: --- → DUPLICATE
Duplicate of bug: 963556
You need to log in before you can comment on or make changes to this bug.