JavaScript Error: "conn.setRadioEnabled is not a function"

RESOLVED FIXED

Status

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: gkw, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression
Dependency tree / graph

Firefox Tracking Flags

(b2g-v1.3 fixed, b2g-v1.4 fixed)

Details

(Reporter)

Description

5 years ago
JavaScript error: http://system.gaiamobile.org:8080/js/airplane_mode.js, line 33: conn.setRadioEnabled is not a function

Not sure if this is likely to be related to:

https://github.com/mozilla-b2g/gaia/blob/f55764b3cfb5937e8ca58835342a67059cd3ad8f/apps/system/js/airplane_mode.js#L33

The line was merged in https://github.com/mozilla-b2g/gaia/commit/3740a75412230da93c71290cffb832ebb9c11e0f#diff-b9732e78e1e53e24fdb29067ef65366dR73 so cc'ing EJ and setting needinfo.

I found this from poking around marifuzz by starting B2G Desktop from rev 4ecd4f2ba149 with Gaia profile rev f55764b.
Flags: needinfo?(ejchen)
(Reporter)

Updated

5 years ago
Blocks: 945140

Updated

5 years ago
Component: Gaia → Gaia::System
Hi Gary, 

I am not familiar with the part you are working, but it seems that this bug happened on B2G desktop based on your comments. 

I noticed Kevin Grandon just added a shim for B2G desktop (https://github.com/mozilla-b2g/gaia/commit/23db31270c0616b433c3a0131ceb524d33348a0f) few days ago. And it seems that he had already added few missing function that will cause javascript error like this. 

I just tested latest Gaia code from master and I don't see any error about this when toggling airplane mode. 

Can you try again or provide more steps about how to reproduce this ? 

Thanks Gary :P
Flags: needinfo?(ejchen)
(Reporter)

Comment 2

5 years ago
> I noticed Kevin Grandon just added a shim for B2G desktop
> (https://github.com/mozilla-b2g/gaia/commit/
> 23db31270c0616b433c3a0131ceb524d33348a0f) few days ago. And it seems that he
> had already added few missing function that will cause javascript error like
> this. 
> 
> I just tested latest Gaia code from master and I don't see any error about
> this when toggling airplane mode. 

Thanks for looking at this!

I tested on 1.3 (mozilla-aurora B2G Gecko, Gaia 1.3 branch), so perhaps that fix in bug 956012 needs to be backported to fix this issue? Bug 956012 seems to show that it only landed on m-c/master.

Setting needinfo from Kevin since he fixed bug 956012.
Flags: needinfo?(kgrandon)
Yes, that may be the problem why it works on master instead of v1.3. 

I think the shim may need to be uplifted to v1.3 because there are some APIs created in v1.3 scope. Let's wait for Kevin's response. 

Thanks :D
Yes, uplifting bug 956012 to 1.3 will likely fix the issue. It is not part of the build, so should be easy enough to uplift. I'll ask for approval in that bug.
Depends on: 956012
Flags: needinfo?(kgrandon)
Now fixed on 1.3, Gary can you check again to see if this is resolved?
(Reporter)

Comment 6

5 years ago
I no longer see this in:

http://ftp.mozilla.org/pub/mozilla.org/b2g/nightly/2014/02/2014-02-04-16-40-00-mozilla-b2g28_v1_3/b2g-28.0.multi.mac64.dmg

Assuming FIXED by bug 956012.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
status-b2g-v1.3: affected → fixed
status-b2g-v1.4: --- → fixed
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.