Cannot import a radicale calendar using caldav import

RESOLVED WONTFIX

Status

defect
RESOLVED WONTFIX
5 years ago
a year ago

People

(Reporter: oria, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:26.0) Gecko/20100101 Firefox/26.0 (Beta/Release)
Build ID: 20131206145143

Steps to reproduce:

build : 1.4
device : mako (nexus-4)
server calendar : radicale
=> Works very good with lightning of thunderbird

1. Add an account CalDav
2. Enter the correct Username, Password and URL
3. Save


Actual results:

Error : "Something is wrong. Try again later."
=> Impossible to sync

logcat : 
E/GeckoConsole( 1151): Content JS WARN at app://calendar.gaiamobile.org/gaia_build_defer_index.js:1 in consoleWarn: [l10n] #error-caldav-unknown is undefined
(Reporter)

Updated

5 years ago
Component: General → Gaia::Calendar
Summary: calendar → Cannot import a radicale calendar using caldav import
I tried this myself with the guest account oria provided (thanks!!)

We use a CalDav handshake... Something like this:

 1. find user's home
 2. find their collections
 3. sync their calendar collection

1. works just fine the url /guest/calendar.ics/ yeilds a home of /guest/
2. Is where things go wrong... When issuing the request the response is 403 (Forbidden) without a response body.

I can see how lightning would work just fine... Given an ical file (which loads just fine) lightning will display that right away. Calendar currently does not have that functionality and needs a CalDAV server which can support some basic CalDAV/WebDAV methods to find the calendar home and issue some commands.
Duplicate of this bug: 956472
(In reply to James Lal [:lightsofapollo] Less responsive until Jan 1 (please email for urgent issues) from comment #1)
> I tried this myself with the guest account oria provided (thanks!!)
> 
> We use a CalDav handshake... Something like this:
> 
>  1. find user's home
>  2. find their collections
>  3. sync their calendar collection
> 
> 1. works just fine the url /guest/calendar.ics/ yeilds a home of /guest/
> 2. Is where things go wrong... When issuing the request the response is 403
> (Forbidden) without a response body.
> 
> I can see how lightning would work just fine... Given an ical file (which
> loads just fine) lightning will display that right away. Calendar currently
> does not have that functionality and needs a CalDAV server which can support
> some basic CalDAV/WebDAV methods to find the calendar home and issue some
> commands.

As reported on dup bug 956472, I have the same issue on my Zimbra calendar. The URL I use is: https://mail.mozilla.com/home/alissy@mozilla.com/Calendar
As suggested on IRC, I tested with only 'https://mail.mozilla.org' as URL and it now works.

Comment 5

4 years ago
Same issue with my Flame (2.1.0.0-prerelease, nightly-b2g34, build 20150103001211) and my own installation of Radicale 0.9 (which runs fine with KOrganizer in KDE).

I tried with the URL https://cal.x.y/myaccount/mycalendar.ics/, or https://cal.x.y. With the first one, It does not take mycalendar.ics, but load an inexistant 'calendar.ics' (which is then automatically created by Radicale). For the second one, there is a message "an error occured, please try later" (translated from french, not sure the real english message is the same I indicate).

Note that with KOrganizer, after indicating my login/password and the first URL, It shows me a list of calendars, so I can indicate which one I want to take. Seeing that, I'm not sure Radicale is well configured (since the calendar I want is indicated in the url...).

@Oria: is your Radicale installation behind Apache (with wsgi) ? (like mine, see http://radicale.org/user_documentation/#idapache-and-mod-wsgi, with the example containing rewrite rules)

Comment 6

4 years ago
Same here on the ZTE Open–C (with default firmeware, since updating is complicated). My Radicale server works fine with Thunderbird+Lightning and Android.

Comment 7

4 years ago
BTW: The error message is "Ein unbekannter Fehler trat auf. Bitte versuchen sie es später noch mal." Really? :( Not helpful at all (it translate to something like "unknown error. try again later.").

Comment 8

4 years ago
I'm running Radicale 0.10, and am largely in the same boat. When I specify a URL of a Calendar, it performs PROPFIND, but doesn't expose any particular calendar. I'm not sure what Firefox OS expects to see when performing PROPFIND, nor what Radicale is returning. I'll keep digging here.
(Reporter)

Comment 9

4 years ago
@laurent, with radicale I use lighttpd only. Now I have nexus 5 "hammerhead" same problem...
(Reporter)

Comment 10

4 years ago
Great news!
Radicale with ffos works! 

My url example is : 
https://myhostname/cal.php/calendars/myusername/default
(Reporter)

Comment 11

4 years ago
Great news!
Radicale with ffos works! 

My url example is : 
https://myhostname/cal.php/calendars/myusername/default
(Reporter)

Comment 12

4 years ago
Great news!
Radicale with ffos works! 

My url example is : 
https://myhostname/cal.php/calendars/myusername/default
(Reporter)

Comment 13

4 years ago
Great news!
Radicale with ffos works! 

My url example is : 
https://myhostname/cal.php/calendars/myusername/default
(Reporter)

Comment 14

4 years ago
Great news!
Radicale with ffos works! 

My url example is : 
https://myhostname/cal.php/calendars/myusername/default
(Reporter)

Comment 15

4 years ago
Great news!
Radicale with ffos works! 

My url example is : 
https://myhostname/cal.php/calendars/myusername/default
(Reporter)

Comment 16

4 years ago
Sorry for the multi post.
And more I confused, I recently replaced radical server by baikal server. Can you delete my last post off topic. Thank You
Hi,

I've got a FxOS (2.2) working fine with Radicale (0.10) on Debian.

Trying to access a particular calendar (https://server/user/calendar.ics) doesn't work.

Trying to access global user DAV space (https://server/user/) works. The Gaia Calendar then fetches all calendars from user space.

Hope it helps.

Comment 18

a year ago
Firefox OS is not being worked on
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.