TypeError: must be encoded string without NULL bytes, not str during virtualenv population

RESOLVED INVALID

Status

()

Core
Build Config
RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: gps, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
All
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
Converting bug 843424 recent comments into a new bug.

---

I'm getting a similar error when configuring twice (first one failed for a different reason), with new VS2012 and mozilla-build install.

mchew@MOZILLA-10915 /c/mozilla-source/mozilla-central
$ ./mach build
 0:00.95 C:/mozilla-build/msys/bin/sh.exe -c c:/mozilla-build/python/python.exe
c:/mozilla-source/mozilla-central/build/pymake/make.py -f client.mk -s
 0:03.17 Adding client.mk options from c:/mozilla-source/mozilla-central/.mozcon
fig:
 0:03.17     FOUND_MOZCONFIG := c:/mozilla-source/mozilla-central/.mozconfig
 0:04.23 Clobber not needed.
 0:04.28 cd obj-i686-pc-mingw32
 0:04.31 c:/mozilla-source/mozilla-central/configure
 0:04.59 Adding configure options from c:/mozilla-source/mozilla-central/.mozcon
fig:
 0:04.59   --disable-webgl
 0:04.99 loading cache ./config.cache
 0:06.13 checking host system type... i686-pc-mingw32
 0:06.60 checking target system type... i686-pc-mingw32
 0:07.05 checking build system type... i686-pc-mingw32
 0:07.08 checking for mawk... no
 0:07.11 checking for gawk... gawk
 0:07.22 checking for python2.7... /c/mozilla-build/python/python2.7
 0:07.30 Creating Python environment
 0:07.44 checking Python environment is Mozilla virtualenv... Traceback (most re
cent call last):
 0:07.44   File "c:\mozilla-source\mozilla-central\obj-i686-pc-mingw32\_virtuale
nv\lib\site.py", line 703, in <module>
 0:07.44     main()
 0:07.44   File "c:\mozilla-source\mozilla-central\obj-i686-pc-mingw32\_virtuale
nv\lib\site.py", line 670, in main
 0:07.44     virtual_install_main_packages()
 0:07.44   File "c:\mozilla-source\mozilla-central\obj-i686-pc-mingw32\_virtuale
nv\lib\site.py", line 611, in virtual_install_main_packages
 0:07.44     if os.path.exists(tk_dir):
 0:07.44   File "c:\mozilla-source\mozilla-central\obj-i686-pc-mingw32\_virtuale
nv\lib\genericpath.py", line 18, in exists
 0:07.44     os.stat(path)
 0:07.44 TypeError: must be encoded string without NULL bytes, not str
 0:07.44 configure: error: Python environment does not appear to be sane.
 0:07.44 ------ config.log ------
 0:07.49 This file contains any messages produced by compilers while
 0:07.49 running configure, to aid debugging if configure makes a mistake.
 0:07.49
 0:07.49 configure:1195: checking host system type
 0:07.49 configure:1216: checking target system type
 0:07.49 configure:1234: checking build system type
 0:07.49 configure:1309: checking for mawk
 0:07.49 configure:1309: checking for gawk
 0:07.49 configure:1395: checking for python2.7
 0:07.49 configure:1505: checking Python environment is Mozilla virtualenv
 0:07.49 configure: error: Python environment does not appear to be sane.
 0:07.49 *** Fix above errors and then restart with\
 0:07.49                "c:/mozilla-build/python/python.exe c:/mozilla-source/mo
zilla-central/build/pymake/pymake/../make.py -f client.mk build"
 0:07.50 c:\mozilla-source\mozilla-central\client.mk:365:0: command 'cd obj-i686
-pc-mingw32 &&  MAKE='c:/mozilla-build/python/python.exe c:/mozilla-source/mozil
la-central/build/pymake/pymake/../make.py'  c:/mozilla-source/mozilla-central/co
nfigure  \
 0:07.50   || ( echo '*** Fix above errors and then restart with\
 0:07.50                "c:/mozilla-build/python/python.exe c:/mozilla-source/mo
zilla-central/build/pymake/pymake/../make.py -f client.mk build"' && exit 1 )' f
ailed, return code 1
 0:07.50 c:\mozilla-source\mozilla-central\client.mk:377:0: command 'c:/mozilla-
build/python/python.exe c:/mozilla-source/mozilla-central/build/pymake/pymake/..
/make.py -f c:/mozilla-source/mozilla-central/client.mk configure' failed, retur
n code 2
 0:07.50 c:\mozilla-source\mozilla-central\client.mk:185:0: command 'c:/mozilla-
build/python/python.exe c:/mozilla-source/mozilla-central/build/pymake/pymake/..
/make.py -f c:/mozilla-source/mozilla-central/client.mk realbuild' failed, retur
n code 2
 0:07.61 0 compiler warnings present.
2
(Reporter)

Comment 1

4 years ago
Monica: Any chance your topsrcdir or topobjdir or mozilla-build directory has non-ascii characters in it?
Flags: needinfo?(mmc)
(Reporter)

Updated

4 years ago
Blocks: 912114
None that I can see.
Flags: needinfo?(mmc)
(Reporter)

Comment 3

4 years ago
Monica: Any chance you can give me access to the machine reproducing this error? Looking at the stack trace, this is very early in Python initialization. I could teach you how to fish, but it would be rather involved. Let me know if you want me to try to teach you.
Flags: needinfo?(mmc)
I fixed this error by blowing away the virtualenv dir, and now I can't reproduce it. I'll re-open if I ever figure out how it happened in the first place. Thanks for following up!
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(mmc)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.