Closed Bug 956481 Opened 6 years ago Closed 6 years ago

Remove ellipsis from some Message menuitems

Categories

(Thunderbird :: Message Reader UI, defect, trivial)

24 Branch
defect
Not set
trivial

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 29.0

People

(Reporter: mseiffarth, Assigned: Paenglab)

References

Details

Attachments

(1 file, 3 obsolete files)

Clicked on the name of one of the other recipients of an e-mail in a message header.
This opened a menu which included a "Compose message to" [sic] option.
Upon clicking that option, a new window, which allowed me to send a message to that person, opened.

Since the clicking of the menu item causes a new window to appear, the menu item should read "Compose message to..." as opposed to "Compose message to".

This is especially jarring because the placement of ellipses in all other menu items of the same menu is correct.
Attached patch add ellipsis (obsolete) — Splinter Review
Seems reasonable. What do you think, Blake?

I changed the label and the accesskey to be in synch in naming.
Assignee: nobody → richard.marti
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #8355777 - Flags: review?(bwinton)
I actually don't think that's consistent with the rest of Thunderbird's UI. Composition commands (Reply, Forward, etc) do not generally include ellipses.
(In reply to Jim Porter (:squib) from comment #2)
> I actually don't think that's consistent with the rest of Thunderbird's UI.
> Composition commands (Reply, Forward, etc) do not generally include ellipses.

Well, the "big buttons" outside of drop-down menus never have ellipses (including such buttons as "Address book", which are really not composition commands).
The buttons inside drop-down menus, when their being clicked upon directly effects the opening of a window, always do (including, say, the "Edit contact..." item).
(In reply to Martin Seiffarth from comment #3)
> The buttons inside drop-down menus, when their being clicked upon directly
> effects the opening of a window, always do (including, say, the "Edit
> contact..." item).

Not so: look at the context menu for a message in the thread pane.

Also, merely opening a new window isn't enough to justify ellipses, at least not according to Microsoft's UI guidelines:

"This doesn't mean you should use an ellipsis whenever an action displays another window—only when additional information is required to perform the action."[1]

We generally treat composition commands as not requiring "additional information" (although they do, in a way). I think we should maintain this consistency of *not* using ellipses for commands that open a composition window.

[1] http://msdn.microsoft.com/en-us/library/windows/desktop/aa511453.aspx
(In reply to Jim Porter (:squib) from comment #4)
> We generally treat composition commands as not requiring "additional
> information" (although they do, in a way). I think we should maintain this
> consistency of *not* using ellipses for commands that open a composition
> window.
> 
> [1] http://msdn.microsoft.com/en-us/library/windows/desktop/aa511453.aspx

I understand your point, but if composition commands are seen as not needing additional information (which I assume is because the goal of the user when clicking on a composition button is to compose an e-mail, meaning there are no additional windows "between" the user and his goal), shouldn't the same apply to, say, the "Edit contact" window?

After all, the goal of the user when pressing "Edit contact" is, presumably, to have Thunderbird open up an "Edit contact" window - meaning that if we were using ellipses as recommended by the Windows guidelines, the "Edit contact" menu item shouldn't have ellipses either (I checked: it does).
Yeah, we could remove the ellipsis from "Edit contact", since it's pretty clear that it'll open a new window. Also from the MS documentation:

"Consequently, any command button whose implicit verb is to 'show another window' doesn't take an ellipsis, such as with the commands About, Advanced, Help (or any other command linking to a Help topic), Options, Properties, or Settings."

Really, we should be removing ellipses from a bunch of menu items all over Thunderbird if we want to follow these guidelines (and it appears Firefox does follow them).
So, I assume someone should close this bug report and open one about there being ellipses where there really shouldn't be?

Don't get me wrong, it's not a high-priority issue by any means, it's just that it's a tad jarring to see ellipses placed apparently incongruously on menu items.
Comment on attachment 8355777 [details] [diff] [review]
add ellipsis

Instead of "SendMessageTo1", what about "SendMailTo", or better "ComposeMessageTo"?

Other than that, it seems good.  r=me.
Attachment #8355777 - Flags: review?(bwinton) → review+
(Note that the r+ has no affect on the ui-r status, and so you should get one of those before this gets checked in.  ;)
Attached patch add ellipsis v2 (obsolete) — Splinter Review
Okay, set to "ComposeMessageTo". I'll add a ui-r? to not to forget it needs one.

If you decide this and other items should have no ellipsis, we can still use this bug and change the bug title.
Attachment #8355777 - Attachment is obsolete: true
Attachment #8355849 - Flags: ui-review?(bwinton)
Attachment #8355849 - Flags: review+
I think Jim is definitely correct. There should be no ellipsis on "Compose Message To...", and it ellipsis should be removed from the "Edit Contact" menu (and indeed other places too).
OS: Windows 7 → All
Hardware: x86_64 → All
Comment on attachment 8355849 [details] [diff] [review]
add ellipsis v2

Let's go with the proposal to remove ellipses, since that seems to be the consensus.  But, for his sins, I propose you get Jim to review and ui-review the next patch.  ;)
Attachment #8355849 - Flags: ui-review?(bwinton) → ui-review-
Attached patch patch (obsolete) — Splinter Review
This patch removes the ellipsis from "Edit as new" context menu and uses "Edit *Message* As New" like it is already in main menu. The patch removes the ellipsis also from "Edit Contact".

I leave the "Create Filter From..." as, I think, it is a special case like "Print..." or "Page setup..." which doesn't act directly on the message. If you think this should also be removed I can do it.
Attachment #8355849 - Attachment is obsolete: true
Attachment #8356233 - Flags: ui-review?(squibblyflabbetydoo)
Attachment #8356233 - Flags: review?(squibblyflabbetydoo)
Summary: "Compose message to" menu item is missing ellipsis → Remove ellipsis from some Message menuitems
Comment on attachment 8356233 [details] [diff] [review]
patch

Review of attachment 8356233 [details] [diff] [review]:
-----------------------------------------------------------------

I agree that we should keep the ellipsis in "Create Filter From...", since "Create Filter From" doesn't imply opening a new window; without the ellipsis, I'd think that it would just automatically create a filter without prompting me. "Edit Contact" and "Compose Message To" both imply pretty strongly that we'll open a new window, so the ellipsis is redundant there.

r=me, although I think we could improve the "Edit Message As New" string.

::: mail/locales/en-US/chrome/messenger/messenger.dtd
@@ +705,5 @@
>  <!ENTITY contextOpenNewTab.label "Open Message in New Tab">
>  <!ENTITY contextOpenNewTab.accesskey "T">
>  <!ENTITY contextOpenConversation.label "Open Message in Conversation">
>  <!ENTITY contextOpenConversation.accesskey "n">
> +<!ENTITY contextEditMsgAsNew.label "Edit Message As New">

I know this is consistent with the Message menu, but I think "Edit As New Message" is clearer.
Attachment #8356233 - Flags: ui-review?(squibblyflabbetydoo)
Attachment #8356233 - Flags: ui-review+
Attachment #8356233 - Flags: review?(squibblyflabbetydoo)
Attachment #8356233 - Flags: review+
Okay, changed to "Edit As New Message".
Attachment #8356233 - Attachment is obsolete: true
Attachment #8356474 - Flags: ui-review+
Attachment #8356474 - Flags: review+
Keywords: checkin-needed
https://hg.mozilla.org/comm-central/rev/6e2eb12e181b
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 29.0
Let's file a followup for changing "Message > Edit Message As New" to "Edit As New Message" too.
Blocks: 957974
Hi all!
I know this topic is solved but I have a question and if you guys could tell me something I would really appreciate this. Here it goes: I work for a company that uses a system that generates a automatic email prepared to be sent. It used to work on Ms Outlook but since we have migrated to thunderbird it is not working. I have read topics here saying it is a bug and we have to use the button to "edit as new". But I have read a lot of posts and I know that we can use line arguments to compose a entire message, for example. I wanna know if there's a command line to "edit as new". I would put this command in an argument in our program to call the screen to edit the message.
Thanks!
You're more likely to get an answer to that question if you ask it on the #thunderbird IRC channel - or, if you can't find an answer there, by opening a separate ticket.
You need to log in before you can comment on or make changes to this bug.