Closed Bug 956571 Opened 7 years ago Closed 7 years ago

Select-All button in text-selection action-bar dismisses action bar and does not select any text

Categories

(Firefox for Android :: Text Selection, defect)

ARM
Android
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox27 --- unaffected
firefox28 - wontfix
firefox29 - affected
fennec 28+ ---

People

(Reporter: aaronmt, Assigned: wesj)

References

()

Details

(Keywords: dataloss, reproducible, testcase)

See test-case. Invoke focus into the field, tap to position the cursor at the end of the text-value (after the 't' in test). The action-bar reveals a single 'Select-All' button. Tap the 'Select-All' button, tap that button and the entire value in the field is removed and nothing happens.

See video for a demonstration: http://www.youtube.com/watch?v=nfMksuN_SME

This is reproducible on Nightly (01/05, 29.0).

--
Asus Nexus 7 (2013, Android 4.4.2)
Summary: Select-All button in text-selection action-bar dismisses action bar and does select all → Select-All button in text-selection action-bar dismisses action bar and does not select any text
It might be performing a text-selection quickly, but the action-bar should not be dismissed; I should be allowed to perform a clipboard operation on the selected text afterwards.
This is also reproducible on my LG Nexus 4 (Android 4.4.2)

http://mobile.theglobeandmail.com/news/politics/purge-of-canadas-fisheries-libraries-a-historic-loss-scientists-say/article16237051/?service=mobile

Paste anything into the top search-box and then tap select-all; the field is wiped.
If this is new to 28 let's find the regression here, tracking.
This is introduced with the blocking bug, bug 768667.
tracking-fennec: ? → 28+
Status: NEW → ASSIGNED
Ping?
Hello?
Flags: needinfo?(wjohnston)
dup of Bug 969929 - GeckEditable loses data?
Sounds like it. Looks like we're still just shaking bugs loose in the IME code.

Instead of duping right now, I'm going to renom this stuff. To be honest, even if we find fixes, this feels too fragile to uplift to me. i.e. its not worth tracking for 28. If this blocks shipping the actionmode, we should look at backing it out.
Flags: needinfo?(wjohnston)
Aaron, now that bug 969929 has landed, can you retest?
Flags: needinfo?(aaron.train)
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Flags: needinfo?(aaron.train)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.