Closed Bug 956579 Opened 8 years ago Closed 7 years ago

Port Bug 955121 - Show participant tooltip when hovering nick in conversation

Categories

(Thunderbird :: Instant Messaging, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 29.0

People

(Reporter: Paenglab, Assigned: Paenglab)

References

Details

Attachments

(1 file)

This bug is to port bug 955121 from IB to TB. It enables the buddyTooltip on conversation nicks.
Attached patch patchSplinter Review
I'll port bug 954653 in other bug.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #8355890 - Flags: review?(florian)
Comment on attachment 8355890 [details] [diff] [review]
patch

aleth, can you have a look at this please?

I'm confused by what we've done with the FillInHTMLTooltip method of convbrowser.xml. I'm confused that it doesn't exist anymore in Instantbird's chat/ folder, but is still here in comm-central's chat/ folder, even though we merged chat/ recently.
Attachment #8355890 - Flags: review?(aleth)
(In reply to Florian Quèze [:florian] [:flo] from comment #2)
> I'm confused by what we've done with the FillInHTMLTooltip method of
> convbrowser.xml. I'm confused that it doesn't exist anymore in Instantbird's
> chat/ folder, but is still here in comm-central's chat/ folder, even though
> we merged chat/ recently.

The last merge (bug 920801) only covers IB bugs landed before 25/09/13. The bug being ported here landed in November.
Depends on: 957918
Comment on attachment 8355890 [details] [diff] [review]
patch

I have not tested this patch myself, but it looks good. Thanks, and sorry for the late review!
Attachment #8355890 - Flags: review?(florian)
Attachment #8355890 - Flags: review?(aleth)
Attachment #8355890 - Flags: review+
Keywords: checkin-needed
https://hg.mozilla.org/comm-central/rev/c47bab814b04

Thanks!
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 29.0
Blocks: 956589
As you are no longer using html namespace in imbuddytooltip.xml, then the xmlns:html could probably be removed:
http://mxr.mozilla.org/comm-central/source/mail/components/im/content/imbuddytooltip.xml#12
Flags: needinfo?(richard.marti)
Blocks: 962035
Created bug 962035 to remove it.
Flags: needinfo?(richard.marti)
Duplicate of this bug: 778534
You need to log in before you can comment on or make changes to this bug.