RuntimeException (NPE) in selecting 'Firefox Account' in Android's Settings

VERIFIED FIXED in Firefox 29

Status

()

VERIFIED FIXED
5 years ago
a year ago

People

(Reporter: aaronmt, Assigned: nalexander)

Tracking

({reproducible})

Firefox 29
Firefox 29
ARM
Android
reproducible
Points:
---

Firefox Tracking Flags

(firefox29 verified, fennec29+)

Details

(Whiteboard: [qa+])

(Reporter)

Description

5 years ago
W/Binder  (  772): Caught a RuntimeException from the binder stub implementation.
W/Binder  (  772): java.lang.NullPointerException
W/Binder  (  772): 	at com.android.server.accounts.AccountManagerService$Session.onResult(AccountManagerService.java:2203)
W/Binder  (  772): 	at android.accounts.IAccountAuthenticatorResponse$Stub.onTransact(IAccountAuthenticatorResponse.java:59)
W/Binder  (  772): 	at android.os.Binder.execTransact(Binder.java:404)
W/Binder  (  772): 	at dalvik.system.NativeStart.run(Native Method)

This RuntimeException currently locks up Android's Settings utility requiring a force-stop needed to undo the damage.

Steps: 

* LG Nexus 5 (Android 4.4.2) → Settings → Accounts → 'Add Account' → 'Firefox Accounts'

--
Nightly (01/05)
Blocks: 808813
(Assignee)

Comment 1

5 years ago
Never seen this one before.  I wonder if this is due to the multiple-SyncAdapter hijinks I'm playing with?  Those are scheduled to go.  This whole Add Account flow is being re-worked, so I expect this to be resolved in the course of the battle, but we'll block on it for release.  Thanks, Aaron!
Whiteboard: [qa+]
tracking-fennec: ? → 29+
(Assignee)

Comment 2

5 years ago
https://hg.mozilla.org/services/services-central/rev/efbfbe311e76
Status: NEW → ASSIGNED
Whiteboard: [qa+] → [qa+][fixed in services]
https://hg.mozilla.org/mozilla-central/rev/efbfbe311e76
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Whiteboard: [qa+][fixed in services] → [qa+]
Target Milestone: --- → Firefox 29
(Reporter)

Updated

5 years ago
Flags: needinfo?(aaron.train)
Keywords: verifyme
(Reporter)

Updated

5 years ago
Status: RESOLVED → VERIFIED
status-firefox29: --- → verified
Flags: needinfo?(aaron.train)
Keywords: verifyme

Updated

a year ago
Product: Android Background Services → Firefox for Android
You need to log in before you can comment on or make changes to this bug.