URLs do not properly cut and paste in HTML compose

RESOLVED DUPLICATE of bug 805359

Status

SeaMonkey
Composer
RESOLVED DUPLICATE of bug 805359
5 years ago
5 years ago

People

(Reporter: Kent G. Budge, Unassigned)

Tracking

SeaMonkey 2.23 Branch
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 8355903 [details]
Corvettes.htm

User Agent: Mozilla/5.0 (X11; Linux i686; rv:26.0) Gecko/20100101 Firefox/26.0 SeaMonkey/2.23 (Beta/Release)
Build ID: 20131210201646

Steps to reproduce:

My whole Web site relies on URLs that are relative, not absolute. I'm cutting and pasting text containing these relatie hyperlinks all the time.


Actual results:

The hyperlinks are converted from relative hyperlinks to absolute file:/// hyperlinks every time I cut and paste them. Every. Single. Time.

For example (file attached): The very first hyperlink, on the world "antisubmarine", is the relative location ../../S/u/Submarines.htm

If I cut and paste this text, the hyperlink is converted in the pasted text to
the absolute location file:///home/kgbudge/html/pwencycl/S/u/Submarines.htm 

So when I upload the page to my Web site, it's all wrong. (Relative locations are the same on my Web site as on my personal computer, which is *the whole point* of using relative locations.)

This can't possibly be considered the right behavior. The link location should remain relative when it is pasted.


Expected results:

They should remain relative hyperlinks, not be converted to absolute hyperlinks. When I cut text containing the relative link ../../S/u/Submarines.htm and paste it somewhere, it should be pasted as ../../S/u/Submarines.htm and not converted to file:///home/kgbudge/html/pwencycl/S/u/Submarines.htm

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 805359
You need to log in before you can comment on or make changes to this bug.