[tarako][build]create "tarako" build

RESOLVED FIXED

Status

Release Engineering
General Automation
P2
normal
RESOLVED FIXED
4 years ago
2 years ago

People

(Reporter: thomas tsai, Assigned: catlee, NeedInfo)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:1.3T+, b2g-v1.3T fixed)

Details

(Whiteboard: [b2g][priority])

Attachments

(14 attachments, 1 obsolete attachment)

377 bytes, patch
seinlin
: feedback+
Details | Diff | Splinter Review
1.34 KB, patch
Details | Diff | Splinter Review
603 bytes, patch
Details | Diff | Splinter Review
6.63 KB, patch
catlee
: review+
nthomas
: checked-in+
Details | Diff | Splinter Review
785 bytes, patch
nthomas
: review+
jlund
: checked-in+
Details | Diff | Splinter Review
1.86 KB, patch
RyanVM
: review+
Details | Diff | Splinter Review
764 bytes, patch
catlee
: review+
nthomas
: checked-in+
Details | Diff | Splinter Review
2.36 KB, patch
hwine
: review+
catlee
: checked-in+
Details | Diff | Splinter Review
861 bytes, patch
Callek
: review+
catlee
: checked-in+
Details | Diff | Splinter Review
1.79 KB, patch
jhopkins
: review+
catlee
: checked-in+
Details | Diff | Splinter Review
973 bytes, patch
nthomas
: review+
catlee
: checked-in+
Details | Diff | Splinter Review
44 bytes, text/x-github-pull-request
mwu
: review-
Details | Review | Splinter Review
4.81 KB, patch
aki
: review+
catlee
: checked-in+
Details | Diff | Splinter Review
1.07 KB, patch
Details | Diff | Splinter Review
(Reporter)

Description

4 years ago
1. Get code and build
git clone https://github.com/sprd-ffos/B2G.git -b sprd
./config.sh sp6821a_gonk4.0
./build.sh

2. update u-boot.bin
adb reboot bootloader
fastboot flash 2ndbl u-boot.bin

3. switch to root under adb shell
adb root
Need to assign install path for "flash.sh gaia".

GAIA_INSTALL_PARENT=/data/local ./flash.sh gaia
(In reply to Kai-Zhen Li from comment #1)
> Need to assign install path for "flash.sh gaia".
> 
> GAIA_INSTALL_PARENT=/data/local ./flash.sh gaia

We really need to get apps installed in /system for production builds though.
Whiteboard: [tarako]
Component: General → General Automation
Product: Firefox OS → Release Engineering
QA Contact: catlee
Thomas, please check new tarako pac on my FTP, support fastboot.
Flags: needinfo?(ttsai)
(Reporter)

Updated

4 years ago
Flags: needinfo?(ttsai)

Updated

4 years ago
Depends on: 961949
We'll need VARIANT=eng builds for automation; I guess someone will want VARIANT=user builds as well, but am not sure.

Comment 5

4 years ago
Created attachment 8369814 [details] [diff] [review]
(dubious?) flash.sh patch

I was able to flash the gonk on my tarako device by applying this patch then doing:

  ./config.sh sp6821a_gonk4.0
  ./build.sh
  ./flash.sh

The patch is against the sprd branch in:

  https://github.com/sprd-ffos/B2G.git

Kai-Zhen, does this look reasonable?
Attachment #8369814 - Flags: feedback?(kli)

Updated

4 years ago
Attachment #8369814 - Attachment is patch: true
There are error about failed patches

Also there are a few patches that I needed to apply to be able to build. Will attach them.

Comment 7

4 years ago
Hub, can you also say what steps you followed?  Using thre steps in comment 5 I did not run into any build errors.
Same steps. One of the build breakage is the good old bug 854389 that came because sprd use their own fork based on the broken Google code.
Created attachment 8370291 [details] [diff] [review]
frameworks/base patch to fix

This fix the frameworks/base build. See 854389
Comment on attachment 8370292 [details] [diff] [review]
sprd.diff

device/sprd fails because of a broken Android.mk
Attachment #8370292 - Attachment filename: sprd.diff → sprd
(Reporter)

Comment 12

4 years ago
James: please update the patch, sprd.diff. It's a half-width font, not a full-width font for ":".
Flags: needinfo?(james.zhang)
Also why is it that after building, gaia has a large number of uncommitted changes?

Can't we just use git branches instead?
This repo is temporary while the device config is upstreamed to the main b2g repo. No need to lose time on details here.
Depends on: 969123
xinhe will take it.
Assignee: nobody → xinhe.yan
Flags: needinfo?(james.zhang)
(In reply to Hubert Figuiere [:hub] from comment #9)
> Created attachment 8370291 [details] [diff] [review]
> frameworks/base patch to fix
> 
> This fix the frameworks/base build. See 854389

OK, I'll cherry-pick this commit.


commit 579c2b4dc12543f53cf3c885b4a8525cfe4a533d
Author: Al Sutton <al@funkyandroid.com>
Date:   Sun Feb 19 08:31:19 2012 +0000

    Xcode 4.3 compatibility checkin
    
    The update compiler in Xcode 4.3 (and 4.4) requires lookups into dependant
    bases of class templates to be qualified. This checkin fixes the issues
    raised by the compiler by implementing the this-> recommendation from
    the llvm page at http://clang.llvm.org/compatibility.html#dep_lookup_bases
    
    Signed-off-by: Al Sutton <al@funkyandroid.com>

diff --git a/include/utils/KeyedVector.h b/include/utils/KeyedVector.h
index 6bcdea4..65165a2 100644
--- a/include/utils/KeyedVector.h
+++ b/include/utils/KeyedVector.h
@@ -122,7 +122,7 @@ ssize_t KeyedVector<KEY,VALUE>::indexOfKey(const KEY& key) const {
 
 template<typename KEY, typename VALUE> inline
 const VALUE& KeyedVector<KEY,VALUE>::valueFor(const KEY& key) const {
-    ssize_t i = indexOfKey(key);
+    ssize_t i = this->indexOfKey(key);
     assert(i>=0);
     return mVector.itemAt(i).value;
 }
@@ -139,7 +139,7 @@ const KEY& KeyedVector<KEY,VALUE>::keyAt(size_t index) const {
 
 template<typename KEY, typename VALUE> inline
 VALUE& KeyedVector<KEY,VALUE>::editValueFor(const KEY& key) {
-    ssize_t i = indexOfKey(key);
+    ssize_t i = this->indexOfKey(key);
     assert(i>=0);
     return mVector.editItemAt(i).value;
 }
@@ -190,7 +190,7 @@ DefaultKeyedVector<KEY,VALUE>::DefaultKeyedVector(const VALUE& defValue)
 
 template<typename KEY, typename VALUE> inline
 const VALUE& DefaultKeyedVector<KEY,VALUE>::valueFor(const KEY& key) const {
-    ssize_t i = indexOfKey(key);
+    ssize_t i = this->indexOfKey(key);
     return i >= 0 ? KeyedVector<KEY,VALUE>::valueAt(i) : mDefault;
 }
blocking-b2g: --- → 1.3T+
Whiteboard: [tarako]
(In reply to James Zhang from comment #16)
> (In reply to Hubert Figuiere [:hub] from comment #9)
> > Created attachment 8370291 [details] [diff] [review]
> > frameworks/base patch to fix
> > 
> > This fix the frameworks/base build. See 854389
> 
> OK, I'll cherry-pick this commit.
> 

Thanks !
Fixed on my side, please repo sync the code.
hi Aki, i believe we have tarako build internally. do you mind confirming? Thanks
Flags: needinfo?(aki)

Comment 20

4 years ago
(In reply to Joe Cheng [:jcheng] from comment #19)
> hi Aki, i believe we have tarako build internally. do you mind confirming?
> Thanks

RelEng doesn't have any instructions on how to build Tarako.
This bug appeared to be a request for RelEng to create an automated Tarako build, but then it became a dev bug.
Flags: needinfo?(aki)
Comment on attachment 8369814 [details] [diff] [review]
(dubious?) flash.sh patch

Review of attachment 8369814 [details] [diff] [review]:
-----------------------------------------------------------------

I think it's reasonable. I use "sp6821"* in my local flash.sh.
Attachment #8369814 - Flags: feedback+
Attachment #8369814 - Flags: feedback?(kli)
Fix frameworks and device/sprd on my side.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED

Updated

4 years ago
See Also: → bug 979136
Duplicate of this bug: 978900
Reopen it due to this issue seems like be a request to generate the Tarako pvt builds.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 25

4 years ago
For the developers who wants to clone tarako build, please following the below steps.

1. git clone https://github.com/mozilla-b2g/B2G
2. cd B2G
3. BRANCH=v1.3t ./config.sh tarako
4. git clone git@github.com:Seinlin/tarako-patches.git -b v1.3t patches
5. ./build.sh -j1
Assignee: xinhe.yan → ying.xu
Flags: needinfo?(tchung)

Comment 26

4 years ago
James, will this repo have the patch you referenced on bug 975232 to fix the USB issues?  I don't see it in the commit history on github, so I am curious.

Thanks
Flags: needinfo?(james.zhang)

Comment 27

4 years ago
(In reply to Clint Talbert ( :ctalbert ) from comment #26)
> James, will this repo have the patch you referenced on bug 975232 to fix the
> USB issues?  I don't see it in the commit history on github, so I am curious.
> 
> Thanks

yes, There is some delay of syncing the code from sprd internal server to public server.
(In reply to Clint Talbert ( :ctalbert ) from comment #26)
> James, will this repo have the patch you referenced on bug 975232 to fix the
> USB issues?  I don't see it in the commit history on github, so I am curious.
> 
> Thanks

repo sync
cd device/sprd
git show 27a4b15ae8c526f538409504acb86643c0cd4daa

commit 27a4b15ae8c526f538409504acb86643c0cd4daa
Author: lianxiang.zhou <lianxiang.zhou@spreadtrum.com>
Date:   Mon Mar 3 15:25:24 2014 +0800

    Bug #275374 usb tethering can not work
    
    [bug number  ] 275374
    [root cause  ]
    [changes     ]
    [side effects]
    [reviewers   ]
    
    Change-Id: Id490f6450d6f755e94b97b1e5adfa5c1e722af34
Flags: needinfo?(james.zhang)

Comment 29

4 years ago
Thanks James, we are testing this patch now, and so far it is looking good. Many thanks!
Clint, wonder if we have all the information we need to generate tarako 1.3T PVT build? thanks
Flags: needinfo?(ying.xu)

Comment 31

4 years ago
I think you can do it.

(In reply to Joe Cheng [:jcheng] from comment #30)
> Clint, wonder if we have all the information we need to generate tarako 1.3T
> PVT build? thanks
Flags: needinfo?(ying.xu)
meant to ni? Clint, sorry about this
Flags: needinfo?(ctalbert)

Comment 33

4 years ago
So, yes, I think I have all the information. The builds are working for me now.

I'll move this to catlee at this point.

Catlee: steps:
export BRANCH=v1.3t
./config.sh tarako
./build.sh -j1

That's what we want for the per-change pvt builds (per change to 1.3t branch). From what I understand, we only want to build and test the fixes landed directly in the 1.3t branch, and without any other patch queues in place. We need this very very soon.
Flags: needinfo?(ctalbert) → needinfo?(catlee)

Updated

4 years ago
Depends on: 982343
(Assignee)

Updated

4 years ago
Assignee: ying.xu → catlee
Flags: needinfo?(catlee)
Priority: -- → P2
Whiteboard: [b2g]
Created attachment 8389467 [details] [diff] [review]
956631_tarako_support-bbotcustom-130311.diff

adds support for normalizing 'tarako'
Attachment #8389467 - Flags: review?(catlee)
(Assignee)

Updated

4 years ago
Depends on: 982360
(Assignee)

Updated

4 years ago
Attachment #8389467 - Flags: review?(catlee) → review+
Created attachment 8389490 [details] [diff] [review]
[buildbot-configs] Add tarako builds

Adds a b2g_mozilla-b2g28_v1_3t_tarako_eng_dep builder, Hg Poller for releases/mozilla-b2g28_v1_3t, and scheduler to hook them together.
Attachment #8389490 - Flags: review?(catlee)
Created attachment 8389493 [details] [diff] [review]
956631_tarako_support-bbotcustom-130311-2.diff

same as before but removes buri-limited-memory
Attachment #8389467 - Attachment is obsolete: true
Attachment #8389493 - Flags: review?(nthomas)
Comment on attachment 8389493 [details] [diff] [review]
956631_tarako_support-bbotcustom-130311-2.diff

lgtm, buri-limited-memory was a tarako stopgap that never got off the ground.
Attachment #8389493 - Flags: review?(nthomas) → review+
Do we need to start running the Bumper Bot on 1.3t now that we're doing per-push builds and smoketesting?
Flags: needinfo?(catlee)
(Assignee)

Comment 39

4 years ago
(In reply to Ryan VanderMeulen [:RyanVM UTC-4] from comment #38)
> Do we need to start running the Bumper Bot on 1.3t now that we're doing
> per-push builds and smoketesting?

Yup, working on the patches for that right now.
Flags: needinfo?(catlee)
(Assignee)

Updated

4 years ago
Depends on: 982397
(Assignee)

Updated

4 years ago
Attachment #8389490 - Flags: review?(catlee) → review+
Comment on attachment 8389493 [details] [diff] [review]
956631_tarako_support-bbotcustom-130311-2.diff

pushed to default: https://hg.mozilla.org/build/buildbotcustom/rev/ff1839766411
Attachment #8389493 - Flags: checked-in+
in production
(Assignee)

Comment 42

4 years ago
Created attachment 8389998 [details] [diff] [review]
in-tree configs for tarako

sources.xml will be generated by the bumper
Attachment #8389998 - Flags: review?(ryanvm)
Attachment #8389998 - Flags: review?(ryanvm) → review+
in production
Created attachment 8390121 [details] [diff] [review]
[tools] buildapi support for branch
Attachment #8390121 - Flags: review?(catlee)
Comment on attachment 8389998 [details] [diff] [review]
in-tree configs for tarako

I went ahead and pushed this to the 1.3t branch. I haven't pushed it to trunk.
https://hg.mozilla.org/releases/mozilla-b2g28_v1_3t/rev/f83c7b48d9cd
(Assignee)

Updated

4 years ago
Attachment #8390121 - Flags: review?(catlee) → review+
Comment on attachment 8390121 [details] [diff] [review]
[tools] buildapi support for branch

https://hg.mozilla.org/build/tools/rev/e2a885bc5e05 + buildapi pulls it automatically.
Attachment #8390121 - Flags: checked-in+
(Assignee)

Comment 48

4 years ago
Created attachment 8391260 [details] [diff] [review]
b2g bumper config for v1.3t
Attachment #8391260 - Flags: review?(hwine)
Comment on attachment 8391260 [details] [diff] [review]
b2g bumper config for v1.3t

Review of attachment 8391260 [details] [diff] [review]:
-----------------------------------------------------------------

lgtm compared to v1.3 - this is new to me code, so if really unsure may also want aki to look
Attachment #8391260 - Flags: review?(hwine) → review+
(Assignee)

Updated

4 years ago
Attachment #8391260 - Flags: checked-in+
(Assignee)

Comment 50

4 years ago
Created attachment 8391313 [details] [diff] [review]
run bumper on v1.3t
Attachment #8391313 - Flags: review?(bugspam.Callek)
Comment on attachment 8391313 [details] [diff] [review]
run bumper on v1.3t

Review of attachment 8391313 [details] [diff] [review]:
-----------------------------------------------------------------

be sure we get nagios updated to watch this .log as well please.
Attachment #8391313 - Flags: review?(bugspam.Callek) → review+
Comment on attachment 8391313 [details] [diff] [review]
run bumper on v1.3t

In production
(Assignee)

Comment 53

4 years ago
Comment on attachment 8391313 [details] [diff] [review]
run bumper on v1.3t

pushed and deployed to production
Attachment #8391313 - Flags: checked-in+
(Assignee)

Updated

4 years ago
Depends on: 983934
(Assignee)

Comment 54

4 years ago
Created attachment 8391709 [details] [diff] [review]
workaround tarako target naming
Attachment #8391709 - Flags: review?
Comment on attachment 8391709 [details] [diff] [review]
workaround tarako target naming

One nit: be more specific what "weird names" means in the comment.
Attachment #8391709 - Flags: review? → review+
(Assignee)

Comment 56

4 years ago
Comment on attachment 8391709 [details] [diff] [review]
workaround tarako target naming

hope to deploy this later today when I have some time to babysit
Attachment #8391709 - Flags: checked-in+
Merged to production.  I have kicked off a new tarako build and will keep an eye on it.
(Assignee)

Updated

4 years ago
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
(Assignee)

Comment 59

4 years ago
The .zip files don't contain anything useful...patch incoming
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 60

4 years ago
Created attachment 8391802 [details] [diff] [review]
fix paths to image files
Attachment #8391802 - Flags: review?(nthomas)
Attachment #8391802 - Flags: review?(nthomas) → review+
seems we need tarako builds also on b2g-inbound at least since tarako fixes land here too like https://hg.mozilla.org/integration/b2g-inbound/rev/e3f743545ef1
11:41 edmorley Seems like the intention was to only be b2g 1.3t branch only https://bugzilla.mozilla.org/attachment.cgi?id=8389490&action=diff
11:42 edmorley Tomcat|sheriffduty: so maybe hide on trunk trees for now and comment in the bug that they need switching off for trunk if not intended there (or else enabling on more than m-c if they want them running after all)
(Assignee)

Updated

4 years ago
Attachment #8391802 - Flags: checked-in+
(In reply to Carsten Book [:Tomcat] from comment #61)
> seems we need tarako builds also on b2g-inbound at least since tarako fixes
> land here too like
> https://hg.mozilla.org/integration/b2g-inbound/rev/e3f743545ef1

Current tarako builds are on the 1.3t branch which is 1.3 + (cherry picked patches from trunk). So we absolutely needs the 1.3t builds, and will need trunk builds soonish (ideally one we are on 1.5)

Comment 64

4 years ago
From the meeting:

[17:22]	<nhirata_>	aki: I have the answer to your build issue after finding the tinderbox build for tarako. the system image system.img can't be larger than 95k else it freezes when trying to flash the phone.
[17:23]	<aki>	nhirata_: i wasn't aware there was a build issue :)  i'll put that in the bug

* jsmith is wondering where nightlies are
* our current upload dir is "mozilla-b2g28_v1_3t-sp6821a_gonk-eng"; is this going to become something more intuitive?
Flags: needinfo?(catlee)
The max size is 95M, not 95k - that would be really hard ;)

Comment 66

4 years ago
(In reply to Aki Sasaki [:aki] from comment #64)
> [17:22]	<nhirata_>	aki: I have the answer to your build issue after finding
> the tinderbox build for tarako. the system image system.img can't be larger
> than 95k else it freezes when trying to flash the phone.
> [17:23]	<aki>	nhirata_: i wasn't aware there was a build issue :)  i'll put
> that in the bug

This should read "95mb", not "95k" :)

Viral: do you know how we can keep the system.img size down?
Flags: needinfo?(vwang)
Aki: as I know the max size of system.img can be 105MB. 
The simplest way to downsize the system.img is move App to /data/local, here is a patch.
https://github.com/Seinlin/tarako-patches/blob/master/all-sp6821a_gonk/gaia/0002-Install-gaia-in-data.patch#L42
(Reporter)

Comment 68

4 years ago
No WIP for tarako now:

1. git clone https://github.com/mozilla-b2g/B2G
2. cd B2G
3. BRANCH=v1.3t ./config.sh tarako
4. ./build.sh -j1
Flags: needinfo?(brhuang)
Flags: needinfo?(atsai)
Aseking, please check this from Thomas. Thanks.
Flags: needinfo?(brhuang) → needinfo?(fyen)

Comment 70

4 years ago
I think comment 67 already provide the patch to move apps to /data
That should reduce the size of system.img.
Flags: needinfo?(vwang)
TPE server use the patches of comment 67 to downsize the system.img. 
And it also generate gaia/gecko packages without patches.
Flags: needinfo?(fyen)
(Reporter)

Comment 72

4 years ago
The system.img is too big to rom update, so remove fonts to shrink rom size.
https://github.com/Seinlin/tarako-patches/blob/v1.3t/all-sp6821a_gonk/external/moztt/0001-shrink-fonts-size.patch

Comment 73

4 years ago
No idea about what to provide? Thomas, could you be specific your question please? Thanks :)
Flags: needinfo?(atsai) → needinfo?(ttsai)
(Reporter)

Comment 74

4 years ago
No WIP now for tarako, so the system.img is over 120MB. We should make PVT build work, so some fonts should be removed to shrink the rom size. The provided patch is to remove fonts to shrink rom size.
Flags: needinfo?(ttsai)
Depends on: 985767
No longer depends on: 985767
Aki, does the suggestion on comment 74 helps? thanks
Flags: needinfo?(aki)
from https://bugzilla.mozilla.org/show_bug.cgi?id=981160#c18, we should take care of localizations as well

Comment 77

4 years ago
(In reply to Joe Cheng [:jcheng] from comment #75)
> Aki, does the suggestion on comment 74 helps? thanks

Comment 67 and comment 72 both have patches to decrease the system.img size, thank you.
When will one/both of these land?
Flags: needinfo?(aki)
Thomas, can we land comment 67 and comment 72 to unblock PVT build for now? thanks
Flags: needinfo?(ttsai)
bug 985363 also talks about multilocale for 1.3T
(In reply to Joe Cheng [:jcheng] from comment #78)
> Thomas, can we land comment 67 and comment 72 to unblock PVT build for now?
> thanks

What does 'PVT' mean? Please ni? me.
Flags: needinfo?(jcheng)
We add all 24 country language which v1.3 support, the system image size is 140MB, exceed about 35MB.

Comment 82

4 years ago
(In reply to James Zhang from comment #80)
> (In reply to Joe Cheng [:jcheng] from comment #78)
> > Thomas, can we land comment 67 and comment 72 to unblock PVT build for now?
> > thanks
> 
> What does 'PVT' mean? Please ni? me.

pvt means private, as in not on the public ftp server.
Let's unblock with English only locale build for PVT. This should make the system.img under than 105MB for flashing. ni? Ttsai for landing such change
Flags: needinfo?(jcheng)
Whiteboard: [b2g] → [b2g][priority]
Created attachment 8395603 [details] [review]
Remove some fonts to reduce system.img size

Hi Michael, I think we need to remove some fonts to make the system.img size small enough for pvt build at this moment. And this pull is only to v1.3t.
Attachment #8395603 - Flags: review?(mwu)

Comment 85

4 years ago
(In reply to Kai-Zhen Li from comment #84)
> Created attachment 8395603 [details] [review]
> Remove some fonts to reduce system.img size
> 
> Hi Michael, I think we need to remove some fonts to make the system.img size
> small enough for pvt build at this moment. And this pull is only to v1.3t.

There's been work on this in bug 985363.
clearing my ni? since others stepped in to help.
Flags: needinfo?(tchung)
can we land attachment 8395603 [details] [review] first so we can generate PVT build? 
it seems like we need some more time to figure out how to properly handle multilocale builds
thanks
Flags: needinfo?(mwu)
(Assignee)

Updated

4 years ago
Flags: needinfo?(catlee)
(Assignee)

Comment 88

4 years ago
Created attachment 8396857 [details] [diff] [review]
enable tarako non-eng and nightlies
Attachment #8396857 - Flags: review?(aki)

Updated

4 years ago
Attachment #8396857 - Flags: review?(aki) → review+
(Assignee)

Updated

4 years ago
Attachment #8396857 - Flags: checked-in+
ni? Marco for comment 87
Flags: needinfo?(mchen)

Comment 90

4 years ago
(In reply to Joe Cheng [:jcheng] from comment #89)
> ni? Marco for comment 87

Hi Joe,

Sorry to that I am not familiar with fonts stuff so I can't give a review then land it.
Flags: needinfo?(mchen)

Comment 91

4 years ago
Mike Wu, 

Please take a look at this and provide help with reviews and moving it forward.

Thanks
Hema
Comment on attachment 8396857 [details] [diff] [review]
enable tarako non-eng and nightlies

this patch is now live http://hg.mozilla.org/build/buildbot-configs/rev/6b1a60e4112c

Comment 93

4 years ago
Comment on attachment 8395603 [details] [review]
Remove some fonts to reduce system.img size

Charis SIL cannot be removed as it is our serif font. There are patches on bug 985363 that you should assist with instead.
Attachment #8395603 - Flags: review?(mwu) → review-
Flags: needinfo?(mwu)
(In reply to Michael Wu [:mwu] from comment #93)
> Charis SIL cannot be removed as it is our serif font. There are patches on
> bug 985363 that you should assist with instead.

Michael, OK, I'll follow this on bug 985363.
(Assignee)

Comment 95

4 years ago
Let's close this bug out. We have builds running. Subsequent issues should be in their own bugs.
(Assignee)

Updated

4 years ago
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
Hi Chris,
do we actually have flashable PVT builds available? 
IIRC, they are too big the be flashed into actual devices
Flags: needinfo?(catlee)

Comment 97

4 years ago
(In reply to Joe Cheng [:jcheng] from comment #96)
> Hi Chris,
> do we actually have flashable PVT builds available? 
> IIRC, they are too big the be flashed into actual devices

I think that's tracked in bug 985363.
Also, I think someone needs to green up the 1.3t branch... https://tbpl.mozilla.org/?tree=Mozilla-B2g28-v1.3t
Flags: needinfo?(catlee)

Comment 98

4 years ago
Temporarily disabled reordering to see if things behave better -
https://github.com/mozilla-b2g/gaia/commit/dfcc7f8fb35f6c17d6e6556e2ef3ff8c7478d06e

Comment 99

4 years ago
(In reply to Michael Wu [:mwu] from comment #98)
> Temporarily disabled reordering to see if things behave better -
> https://github.com/mozilla-b2g/gaia/commit/
> dfcc7f8fb35f6c17d6e6556e2ef3ff8c7478d06e

Reverted in https://github.com/mozilla-b2g/gaia/commit/17e3c51c039dde2bcd2c7ac0e55076f15a08d199 . No apparent change.

Comment 100

4 years ago
Created attachment 8398274 [details] [diff] [review]
Avoid race in kernel build

It looks like we're trying to build the kernel and install the kernel headers at the same time. This patch should eliminate the problem, though I can't verify it locally.

Comment 101

4 years ago
James, would it be possible to commit this patch (Avoid race in kernel build) to the kernel repo? I think it'll help with our build issues here.
Flags: needinfo?(james.zhang)
status-b2g-v1.3T: --- → fixed
(In reply to Michael Wu [:mwu] from comment #101)
> James, would it be possible to commit this patch (Avoid race in kernel
> build) to the kernel repo? I think it'll help with our build issues here.

Ying has fixed it.
Flags: needinfo?(james.zhang)
(Reporter)

Updated

4 years ago
Flags: needinfo?(ttsai)

Comment 103

2 years ago
trying to build fot alcatel one touch fire c, build.sh fails with following msg

"-- Could NOT find procps (missing:  PROCPS_LIBRARY PROCPS_INCLUDE_DIR) 
CMake Error at CMakeLists.txt:256 (message):

GNU 4.4.x compiler does not support C++11"..

>>log  from errorLog file is
/home/nitturis/firefox/new/B2G/prebuilt/linux-x86/toolchain/arm-linux-androideabi-4.4.x/bin/arm-linux-androideabi-g++   -DANDROID -fexceptions -frtti -fpic -Wno-psabi --sysroot=/home/nitturis/firefox/new/B2G/prebuilt/ndk/android-ndk-r7/platforms/android-9/arch-arm -funwind-tables -finline-limit=64 -fsigned-char -march=armv7-a -mfloat-abi=softfp -mfpu=vfpv3-d16 -fdata-sections -ffunction-sections -Wa,--noexecstack  -fvisibility=hidden -DCXX_COMPILER_FLAG_STD_GNUXX11 -fPIE -isystem /home/nitturis/firefox/new/B2G/prebuilt/ndk/android-ndk-r7/platforms/android-9/arch-arm/usr/include -isystem /home/nitturis/firefox/new/B2G/prebuilt/ndk/android-ndk-r7/sources/cxx-stl/gnu-libstdc++/include -isystem /home/nitturis/firefox/new/B2G/prebuilt/ndk/android-ndk-r7/sources/cxx-stl/gnu-libstdc++/libs/armeabi-v7a/include -isystem /home/nitturis/firefox/new/B2G/prebuilt/ndk/android-ndk-r7/sources/cxx-stl/gnu-libstdc++/include/backward    -std=gnu++11 -o CMakeFiles/cmTryCompileExec4144841629.dir/src.cxx.o -c /home/nitturis/firefox/new/B2G/out/target/apitrace/CMakeFiles/CMakeTmp/src.cxx
cc1plus: error: unrecognized command line option "-std=gnu++11"
Flags: needinfo?(thomas)
You need to log in before you can comment on or make changes to this bug.