List of suggested words in context menu is being increased after every right mouse click!

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
P3
normal
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: Quoc Trinh, Unassigned)

Tracking

26 Branch
x86_64
Windows 8.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8356095 [details]
context_menu_with_many_suggested_words.png

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0 (Beta/Release)
Build ID: 20131205075310

Steps to reproduce:

1. I type a incorrect English word in Facebook.
2. I click right mouse on above word to get suggested correct words. A list of correct words is showing in context menu.
3. I select a correct word in above list.
4. Incorrect words is changed to correct word. (expected)
5. After that, I click right mouse on any other place (in Firefox windows), list of suggested words (in step 2) is multiplied.
6. I do step 5 again, list of words is still being increased.



Actual results:

List of suggested words in context menu is increased multiple even right mouse is not clicked on incorrect word.


Expected results:

List of suggested words should be removed from context menu if user does not click right mouse on incorrect word
(Reporter)

Updated

4 years ago
Severity: normal → major
Priority: -- → P3
I was unable to reproduce this issue on windows 8.1 64-bit using Firefox 26 (Build ID: 20131205075310) and the latest Nightly (Build ID: 20140113030203).

Could you please let me know:
1. have you tried reproducing this issue in Safe Mode?
* how-to: https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode
2. have you tried reproducing this issue using a new profile?
* how-to: https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
3. have you tried resetting Firefox before attempting to reproduce this issue again?
* how-to: https://support.mozilla.org/en-US/kb/reset-firefox-easily-fix-most-problems
Flags: needinfo?(quoc.trinh)
(Reporter)

Comment 2

4 years ago
Created attachment 8361115 [details]
multiple_same_suggested_words.zip
Flags: needinfo?(quoc.trinh)
(Reporter)

Comment 3

4 years ago
Hi Andrei,

1. This issue does NOT happen in Safe Mode.
2. This issue does NOT happen with new profile.
3. I tried to re-start Firefox sometime but, issue always happens in my normal setup.
I attached some more screenshots of issue.

Br,
Quoc
(In reply to Quoc Trinh from comment #3)
> Hi Andrei,
> 
> 1. This issue does NOT happen in Safe Mode.
> 2. This issue does NOT happen with new profile.
> 3. I tried to re-start Firefox sometime but, issue always happens in my
> normal setup.
> I attached some more screenshots of issue.
> 
> Br,
> Quoc

Hi Quoc,

This issue is definitely related to your setup and might be caused by a specific add-on you have installed since it's also not reproducible in Safe Mode. I strongly suggest creating and using a new profile instead of your current one.
Severity: major → normal
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.