Load first run on start page for the first 3 tabs

VERIFIED FIXED in Firefox 28

Status

defect
P2
normal
VERIFIED FIXED
6 years ago
5 years ago

People

(Reporter: rsilveira, Assigned: rsilveira)

Tracking

unspecified
Firefox 29
x86_64
Windows 8.1
Dependency tree / graph
Bug Flags:
in-qa-testsuite -
in-testsuite -

Firefox Tracking Flags

(firefox28 verified, firefox29 verified)

Details

(Whiteboard: [beta28] [feature] p=1)

Attachments

(1 attachment, 1 obsolete attachment)

After discussion on bug 951818 we're making the start page load on the first 3 times the start page is loaded for v1. A long term solution will require l10 and be handled in v2 on bug 951818.
p=1
Blocks: metrov1it22
Status: NEW → ASSIGNED
Priority: -- → P2
QA Contact: jbecerra
Whiteboard: [beta28] [feature] p=1
Posted patch Patch v1 (obsolete) — Splinter Review
Using a pref to keep track of count, don't need the firstrun code in BrowserCLH anymore.
Attachment #8358066 - Flags: review?(mbrubeck)
Comment on attachment 8358066 [details] [diff] [review]
Patch v1

Review of attachment 8358066 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/metro/base/tests/mochitest/head.js
@@ +21,5 @@
>  /*=============================================================================
> +  Test prefs
> +=============================================================================*/
> +
> +Services.prefs.setIntPref("browser.firstrun.count", 0);

Another way to do this is here:
http://dxr.mozilla.org/mozilla-central/source/testing/profiles/prefs_general.js

That might be a good idea since it will also be used by any metro tests added in other directories in the future.
Attachment #8358066 - Flags: review?(mbrubeck) → review+
Cool, didn't know about that prefs file. Made the change and landed:
https://hg.mozilla.org/integration/fx-team/rev/949aaa3b5b8f
https://hg.mozilla.org/mozilla-central/rev/949aaa3b5b8f
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 29
Posted patch Patch v2Splinter Review
Patch that landed - with review comment addressed.
Attachment #8358066 - Attachment is obsolete: true
Attachment #8360046 - Flags: review+
Comment on attachment 8360046 [details] [diff] [review]
Patch v2

[Approval Request Comment]
Bug caused by (feature/regressing bug #): None.
User impact if declined: First run experience will go away too quickly.
Testing completed (on m-c, etc.): On m-c since 2014-01-13
Risk to taking this patch (and alternatives if risky): Very low, metro change only.
String or IDL/UUID changes made by this patch: None.
Attachment #8360046 - Flags: approval-mozilla-aurora?
Attachment #8360046 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Does this have in-testsuite tests?
Flags: needinfo?(rsilveira)
Flags: in-testsuite?
No. It does change a pref to not load the feature in tests though.
Flags: needinfo?(rsilveira)
I believe we'll have mozmill running Metro Firefox soon.  This might be a good case for a mozmill test.
in-qa-testsuite? as per comment 10.
Flags: in-qa-testsuite?(hskupin)
Mozilla/5.0 (Windows NT 6.3; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0
Mozilla/5.0 (Windows NT 6.3; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0

Verified as fixed on latest Aurora (build ID: 20140122004004) and latest Nightly (build ID: 20140122030521).
Status: RESOLVED → VERIFIED
Setting in-testsuite- and in-qa-testsuite- since we don't support Metro anymore
Flags: in-testsuite?
Flags: in-testsuite-
Flags: in-qa-testsuite?(hskupin)
Flags: in-qa-testsuite-
You need to log in before you can comment on or make changes to this bug.