[B2G][Settings]Link within Do Not Track page responding inappropriately when selected by user

RESOLVED DUPLICATE of bug 946807

Status

Firefox OS
Gaia::Settings
RESOLVED DUPLICATE of bug 946807
5 years ago
5 years ago

People

(Reporter: Montoya Clemmons (MClemmons), Assigned: gasolin@mozilla.com)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:1.3+, b2g-v1.2 unaffected, b2g-v1.3 affected)

Details

(Whiteboard: dogfood1.3, URL)

(Reporter)

Description

5 years ago
Description:
User selection of the Learn More hyperlink within the Do Not Track page of the Settings App causes a black screen to appear. 

Repro Steps:
1) Updated buri to BuildID: 20140106004001
2) Tap Settings App
3) Tap Do Not Track
4) Tap Learn More hyperlink

Actual:
Screen goes black 

Expected:
User taken to page regarding Do Not Track features

Environmental Variables:
Device: buri 1.3 MOZ
BuildID: 20140106004001
Gaia: 35a60b82f8cf2d759939a350e2dadbb9d8b2f5dc
Gecko: a43cb4b322d3
Version: 28.0a2

Notes:
Repro frequency: 100% (10 of 10)
See attached: video clip
Other notes: Attempted with Wifi off and Cellular data off. Attempted with Wifi on and Cellular data on. Attempted with Wifi off and Cellular data on. Attempted with Wifi on and Cellular data off. Behavior was consistent as actual result of a black screen displayed each time.
(Reporter)

Comment 1

5 years ago
This issue does not reproduce on buri 1.2. Selecting the hyperlink Learn more takes user to the Do Not Track FAQ page. 

Environmental Variables:
Device: buri 1.2 MOZ
BuildID: 20140106004001
Gaia: 8441587c3b352e052fee07665c21fd192540f19f
Gecko: d552c08a72d0
Version: 26.0
RIL Version: 01.02.00.019.102
status-b2g-v1.2: --- → unaffected
status-b2g-v1.3: --- → affected

Updated

5 years ago
blocking-b2g: --- → 1.3?
Keywords: regression, regressionwindow-wanted

Updated

5 years ago
QA Contact: mvaughan

Comment 2

5 years ago
This issue started reproducing on the 11/28/13 1.3 build.

- Works -
Environmental Variables:
Device: Buri v1.3 MOZ RIL
BuildID: 20131127040203
Gaia: d4b9a3d271f0451b4d903a03c2b931b8cc092041
Gecko: 6ecf0c4dfcbe
Version: 28.0a1
Firmware Version: V1.2_US_20131115

- Broken -
Environmental Variables:
Device: Buri v1.3 MOZ RIL
BuildID: 20131128040201
Gaia: 0d57ec2801ae125ec855a19cf956ab118660d694
Gecko: a5e7f611546f
Version: 28.0a1
Firmware Version: V1.2_US_20131115
Keywords: regressionwindow-wanted
Triage: +'ing, regression

I suspect this is due to some changes made in activity handling somewhere, maybe in the Browser app. The first time the link is pressed the phone quickly goes to Browser app but switched back instantly. The second time the link is pressed it goes to blank.
blocking-b2g: 1.3? → 1.3+
Fred, please investigate this. Thanks!
Assignee: nobody → gasolin
Flags: needinfo?(gasolin)
(Assignee)

Comment 5

5 years ago
@mclemmons I can't reproduce this in either 1.3 or 1.4 on 1/19 branch

master 48797fee915e5fa47ad2f8e3ddd4802c640a573b
1.3 22bc6be5b76cdc6d4e9667ff070979041a20ce2f

Can you help double confirm if this issue has been resolved by some other issues.
Flags: needinfo?(gasolin) → needinfo?(mclemmons)
(Assignee)

Comment 6

5 years ago
I mean 1/9 branch
Ivan, what's the date of the build we were testing on Tue triage?
Flags: needinfo?(itsay)
Oh - I know what this is. This is fixed in bug 946807.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(mclemmons)
Flags: needinfo?(itsay)
Resolution: --- → DUPLICATE
Duplicate of bug: 946807
(In reply to Jason Smith [:jsmith] from comment #8)
> Oh - I know what this is. This is fixed in bug 946807.
> 
> *** This bug has been marked as a duplicate of bug 946807 ***

Woot!
You need to log in before you can comment on or make changes to this bug.