on moving window beyond screen limits, window behaves abnormal.

VERIFIED FIXED in Future

Status

()

P3
normal
VERIFIED FIXED
20 years ago
18 years ago

People

(Reporter: desale, Assigned: vidur)

Tracking

({testcase})

Trunk
Future
x86
Windows 95
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [TESTCASE])

Attachments

(1 attachment)

(Reporter)

Description

20 years ago
If we try to move window beyond screen limits. Window minimizes on its own and
even after trying to maximize it, it does not. For maximizing it you have to
click rightmouse on window [which is minimized] and select "Maximize". After
that if you try to make window smaller by clicking middle button from three
buttons at upper right corner of window, it still minimizes window instead of
making it smaller.

PRODUCT: Seamonkey [Apprunner/ Viewer]
BUILD: 07-08-08.

STEPS TO REPRODUCE:

1] Please copy the code I'm providing. Save it as HTML file.
3] Use smaller window. [Don't make it bigger]
2] Open this HTML file in apprunner as well as viewer.
3] You'll see window is minimized on its own.
4] Now just click mouse on minimized window. [You'll see nothing happens. Here
you expect it to maximize again]
5] Now click right mouse button and click "MAximize" in menu. [It will restore
the window.]
6] Now after restoreing you'll see window size is bigger. Initially it was
smaller. [It became bigger on its own.]
7] Now click middle button of three buttons on upper right corner of window.
[Which is used to make window smaller or bigger.]
You expect window to become small, but actually it minimizes window down.

CODE:

<html>
<head>
<title>Test Page</title>
</head>
<body>
<form name="workform">
<SCRIPT LANGUAGE="JavaScript">
window.screenX=0;
window.screenY=0;

self.moveBy(2000,2000)

</SCRIPT>
</form>
</body>
</html>

END OF CODE:

Comment 1

20 years ago
Created attachment 1092 [details]
Original code snippet as attachment

Updated

20 years ago
Summary: on moving window beyond screen limits, window behaves abnormal. → on moving window beyond screen limits, window behaves abnormal.
Whiteboard: [TESTCASE]

Comment 2

20 years ago
It behaves as expected using 1999-08-01-16-M9 on Windows 98.
I think there are a couple of misunderstandings in the original report:
  in point 3] the reporter says the window is minimized on its own... I think
  what really happens is that it pops up on the screen in a default location,
  starts processing the content and when "self.moveBy(2000,2000)" executes
  the reporter thinks the window was minimized ?

  in point 4] the reporter says that a click in the taskbar should MAXIMIZE
  the window... This is a mistake, it should RESTORE the window.

IMHO this bug should probably be marked INVALID, unless this is a specific
Windows 95 issue (and if so, it is a Win95 bug, not a Mozilla bug).
(Reporter)

Comment 3

20 years ago
I guess, I understand the difference between window going beyond screen limits
and minimizing. Please test it with Win-95 and Win-NT.
Window is minimized, and if its not the on clicking rightmouse botton on
task-bar why we can see word "Maximize" highlighted. And what about later
problems of minimizing window on clicking the middle button of three buttons on
upper right corner. I still think it minimizes window and I don't agree that its
a mistake that I'm expecting window to be maximized on clicking taskbar.

And please test it carefully before making any comments on that, coz bug# 9886,
you marked it works for me and I had to re-open the bug.
So is the bug here that self.MoveBy(2000,2000) minimizes the window?  If not,
this isn't a DOM bug and we should hand it to someone else.
Moving all non-DOM[012], non-crash bugs to M15.
(Assignee)

Comment 6

19 years ago
In an attempt to get my bug list in order again, marking all the bugs I have
currently as ASSIGNED.
Bulk moving [testcase] code to new testcase keyword. Sorry for the spam!
Keywords: testcase
Pushing to M18.
Target Milestone: M15 → M18
This bug has been marked "future" because the original netscape engineer
working on this is over-burdened. If you feel this is an error, that you or
another known resource will be working on this bug,or if it blocks your work
in some way -- please attach your concern to the bug for reconsideration.
Target Milestone: M18 → Future
(Reporter)

Comment 10

18 years ago
Johnney I checked this one with 2000-081105 and seems like this problem is 
fixed.
Should I mark it fixed or you wanna investigate anything about it ?
It looks fixed, and I don't see problem there any more.
Wonderful! Your word is enough for me, marking FIXED.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 12

18 years ago
Verified with 2001-020608.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.