if the sdcard is blank there's a blank white button at the bottom of the error message saying that you need to create videos.

RESOLVED DUPLICATE of bug 955887

Status

RESOLVED DUPLICATE of bug 955887
5 years ago
5 years ago

People

(Reporter: nhirata, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

Created attachment 8356282 [details]
2014-01-06-14-42-40.png

1. place a blank SDcard (or one without videos)
2. launch the video app.

Expected: option to go to camera app or load youtube video
Actual: error message and option with a big white button but it's not labeled.

Notes:
Gaia      9a222ac02db176e47299bb37112ae40aeadbeca7
Gecko     http://hg.mozilla.org/mozilla-central/rev/14ac61461f2a
BuildID   20140106040201
Version   29.0a1
ro.build.version.incremental=eng.archermind.20131114.105818
ro.build.date=Thu Nov 14 10:58:33 CST 2013

Comment 1

5 years ago
Naoki - What is happening when you click on that button. Wondering if the button title is not visible or same color as white.

Russ, can you take a look at this and see whats going on.
Assignee: nobody → rnicoletti
I'm not able to reproduce the problem in nightly or on the device (buri) using gaia 48797fee915e5fa47ad2f8e3ddd4802c640a573b. In both cases I see the "Go to Camera" label on the white button at the bottom of the screen. I am attaching screen shots from nighly and the device.

Can you test again with the latest gaia code? Thanks.
Created attachment 8358081 [details]
from_nightly.png

In nightly when no video is on system
Created attachment 8358085 [details]
When no videos on device
Assignee: rnicoletti → nhirata.bugzilla
When I click on the button it goes to the camera app.
Russn, are you using an engineering build or did you do "make production"?  maybe that might be the difference?
See Also: → bug 953300
Created attachment 8358710 [details]
No videos on buri device

ok, when I use the following command-line

sudo ./auto_flash_from_pvt.sh --version=v1.2.0 --device=buri --full --eng

I'm now not seeing any button. See attached screen shot.

When I use my dev build, gaia b58131a2a3a7a9c6e927b02ac87a366d051fa043, I do see the button and tapping it goes to the camera.
This button is added at bug 915039. That's newly added button. As to the text, that's a bug of l10n. The synchronizing code of l10n to hg is broken now: http://hg.mozilla.org/gaia-l10n/en-US/summary, according to bug 957945 comment 3 by :Pike.

If we open hg of l10n, the last commit happened at Dec. 19, 2013. All texts added after that time are missing in its following build. So, the missing text bug of message app is the same issue.

I was told the same bug but with different bug number few days ago, bug 957945. So, I didn't notice this bug. They are duplicated. I will keep this one and make another one is duplicate.
Duplicate of this bug: 957945
For the reason of different symptom of comment 2, 3, 4 and comment 7, we need to build with multi-locale resources in gaia to see this issue. If we build the app just from github, we don't find the issue.

Comment 11

5 years ago
The code should fall back to en-US for missing strings, so this shouldn't be a localization problem.

I wonder if it's multi-locale optimization or something.
Assignee: nhirata.bugzilla → nobody
(In reply to Axel Hecht [:Pike] from comment #11)
> The code should fall back to en-US for missing strings, so this shouldn't be
> a localization problem.

Yes, it falls back to en-US for missing strings. Those texts are newly added but not included in the en-US hg repository. So, we don't have those texts in en-US.
duping.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 955887
You need to log in before you can comment on or make changes to this bug.