Closed Bug 956904 Opened 6 years ago Closed 6 years ago

Mochitests on debug b2g-emulator seem to fail because of file access race condition

Categories

(Core Graveyard :: DOM: Apps, defect)

x86
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
mozilla31

People

(Reporter: gwagner, Assigned: marco)

References

Details

Intermittent failure that doesn't show up in optimize builds.
For example:
https://tbpl.mozilla.org/php/getParsedLog.php?id=32542493&tree=Pine&full=1

grep for
19:33:19     INFO -  -*- Webapps.jsm : Saving /data/local/webapps/webapps.json
19:33:19     INFO -  -*- Webapps.jsm : Saving /data/local/webapps/webapps.json
I think this is caused by using OS.File to write the file. Can we give more time to execute these tests?
This was probably fixed by bug 981085. I'm marking as FIXED, let's reopen if this shows up again.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Assignee: nobody → mar.castelluccio
Depends on: 981085
Target Milestone: --- → mozilla31
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.