Closed Bug 956907 Opened 6 years ago Closed 6 years ago

incorrect icon used for marked state on social marks button

Categories

(Firefox Graveyard :: SocialAPI, defect)

26 Branch
x86
macOS
defect
Not set

Tracking

(firefox26 wontfix, firefox27+ verified, firefox28+ verified, firefox29 unaffected)

VERIFIED FIXED
Firefox 27
Tracking Status
firefox26 --- wontfix
firefox27 + verified
firefox28 + verified
firefox29 --- unaffected

People

(Reporter: mixedpuppy, Assigned: mixedpuppy)

Details

Attachments

(1 file)

social marks has the state of its icons flipped.  this was fixed for australis when some code was reorganized, but beta/aurora still suffer form this.
Assignee: nobody → mixedpuppy
Attachment #8356293 - Flags: review?(felipc)
Comment on attachment 8356293 [details] [diff] [review]
fix icons used for marked/unmarked state

or markh
Attachment #8356293 - Flags: review?(mhammond)
Attachment #8356293 - Flags: review?(mhammond)
Attachment #8356293 - Flags: review?(felipc)
Attachment #8356293 - Flags: review+
Comment on attachment 8356293 [details] [diff] [review]
fix icons used for marked/unmarked state

[Approval Request Comment]
Bug caused by (feature/regressing bug #): socialmarks.  test provider had icons switched as well, so bug was not caught visually.  I caught the issue during a refactoring of this code in australis
User impact if declined: state of social mark appears incorrectly
Testing completed (on m-c, etc.): holly
Risk to taking this patch (and alternatives if risky): low
String or IDL/UUID changes made by this patch: none
Attachment #8356293 - Flags: approval-mozilla-beta?
Attachment #8356293 - Flags: approval-mozilla-aurora?
Attachment #8356293 - Flags: approval-mozilla-beta?
Attachment #8356293 - Flags: approval-mozilla-beta+
Attachment #8356293 - Flags: approval-mozilla-aurora?
Attachment #8356293 - Flags: approval-mozilla-aurora+
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Do we have tests to ensure the correct icon is showing?
Flags: in-testsuite?
Keywords: verifyme
Hi Shane,  I assume that this bug refers to the fact that the mark button (flag) was displaying its state color under Mac OS X, in an opposite way of how it should have. The correct behavior is: grey flag if the page is unmarked, red flag if the page is marked - please let me know if my assumptions are correct or not.

If my assumptions are indeed correct, then I confirm the fix on Mac OS X 10.8.5 and Mac OS X 10.9.1 using:
- the latest Beta (BuildID: 20140116125114)
- the latest Aurora (BuildID: 20140116004003)
Flags: needinfo?(mixedpuppy)
(In reply to Andrei Vaida, QA [:AndreiVaida] from comment #7)
> The correct behavior is: grey flag if the page is
> unmarked, red flag if the page is marked - please let me know if my
> assumptions are correct or not.

Hi Andrei, yes that would be correct.
Flags: needinfo?(mixedpuppy)
(In reply to Shane Caraveo (:mixedpuppy) from comment #8)
> (In reply to Andrei Vaida, QA [:AndreiVaida] from comment #7)
> > The correct behavior is: grey flag if the page is
> > unmarked, red flag if the page is marked - please let me know if my
> > assumptions are correct or not.
> 
> Hi Andrei, yes that would be correct.

Thank you for the quick reply, marking this issue as verified.
Status: RESOLVED → VERIFIED
Keywords: verifyme
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.