[Building blocks] Icons need to be updated for the 'organic' skin

RESOLVED FIXED

Status

Firefox OS
Gaia::Settings
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: Montoya Clemmons (MClemmons), Assigned: kaze)

Tracking

(Blocks: 1 bug, {regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:1.3+, b2g-v1.2 unaffected, b2g-v1.3 fixed)

Details

(Whiteboard: dogfood1.3)

Attachments

(4 attachments)

(Reporter)

Description

4 years ago
The (+) sign blends with the white background and is difficult to see to add a contact name and number for Authorized Fixed Dialing numbers

Repro Steps:
1) Updated buri to BuildID: 20140106004001
2) Tap Settings App
3) Tap Call Settings
4) Tap Fixed dialing numbers
5) Tap Authorized numbers

Actual:
Screen displays with header reading 'Authorized numbers' but at various angles, the (+) sign is difficult to see and select to the right of this text

Expected:
Screen displays with header of 'Authorized numbers' but the (+) sign is easier to see and select to the right of this text

Environmental Variables:
Device: buri 1.3 MOZ
BuildID: 20140106004001
Gaia: 35a60b82f8cf2d759939a350e2dadbb9d8b2f5dc
Gecko: a43cb4b322d3
Version: 28.0a2


Notes:
Repro frequency: 100% (10 of 10)
See attached: screenshot
(Reporter)

Comment 1

4 years ago
Created attachment 8356337 [details]
Attachment of Screenshot at Angle
(Reporter)

Comment 2

4 years ago
This issue does not reproduce on Buri 1.2. The display of the (+) sign is clear from all angles. 

Environmental Variables:
Device: buri 1.2 MOZ
BuildID: 20140106004001
Gaia: 8441587c3b352e052fee07665c21fd192540f19f
Gecko: d552c08a72d0
Version: 26.0
status-b2g-v1.2: --- → unaffected
status-b2g-v1.3: --- → affected
This is a visual refresh regression & a bad one at that - the white plus button is quite hard to see.
Keywords: regression

Updated

4 years ago
Blocks: 925925

Updated

4 years ago
blocking-b2g: --- → 1.3?
(In reply to Jason Smith [:jsmith] from comment #3)
> This is a visual refresh regression & a bad one at that - the white plus
> button is quite hard to see.

Triage: agree. Need new asset.

Patryk, could you update the asset here?

Joe, who should be following up the FDN feature?
blocking-b2g: 1.3? → 1.3+
Flags: needinfo?(padamczyk)
Flags: needinfo?(jcheng)
Kaze, mind taking? thanks
Flags: needinfo?(jcheng) → needinfo?(kaze)
Created attachment 8356614 [details]
image assets (+ icon)

Hi, I've attached updated image assets in gray.  Please let me know if anything else is needed.  Thanks!
Flags: needinfo?(padamczyk)
(Assignee)

Updated

4 years ago
Assignee: nobody → kaze
Flags: needinfo?(kaze)
(Assignee)

Comment 7

4 years ago
This is a building block issue. The shared/style/headers/images/icons folder is messy:
 • the `organic' folder contains icons for… the `dark' variant (⇒ let’s rename it `dark');
 • most icons in size @2x are not consistent with @1x / @1.5x (wrong color and/or shadow);
 • some filenames include dashes instead of underscores.

Working of a fix. I’ll probably need a lot of new icons.
(Assignee)

Comment 8

4 years ago
Created attachment 8357182 [details] [review]
patch

Eric, following our discussion on IRC I’ve removed all @2x icons since most of them were inconsistent with the @1x and @1.5x ones.

To finish this patch, I’d need dark versions of all these icons:
  • compose.png
  • edit.png
  • send.png
  • menu.png
  • options.png
  • user.png
  • up.png
  • down.png

… and we might also need @1.5x versions of the up.png and down.png icons.
Flags: needinfo?(epang)
(Assignee)

Comment 9

4 years ago
Created attachment 8357187 [details]
screenshot — after patch

Updated

4 years ago
Flags: needinfo?(epang)
(Assignee)

Comment 10

4 years ago
Comment on attachment 8357182 [details] [review]
patch

After a quick discussion with Eric on IRC, turns out we don’t need to add these icons for now. Let’s wait for someone to actually need them in a specific case.

Pavel, are you the right person to review this? :-)
Attachment #8357182 - Flags: review?(pivanov)
(Assignee)

Updated

4 years ago
Duplicate of this bug: 947181
(Assignee)

Updated

4 years ago
Summary: [B2G][Settings]Button to add contact name and number for Authorized Fixed Dialing numbers is difficult to view → [Building blocks] Icons need to be updated for the 'organic' skin
Comment on attachment 8357182 [details] [review]
patch

Sure,

the pleasure is all mine :)
Attachment #8357182 - Flags: review?(pivanov) → review+

Updated

4 years ago
Group: qualcomm-confidential
What's left to do on this bug?

Why is this bug being marked as qualcomm-confidential?
Flags: needinfo?(kyee)
Flags: needinfo?(kaze)

Comment 14

4 years ago
I have no idea what happened here :/   I might have slipped up on the keyboard -- not even sure what happened.   How do I remove the flag?
Flags: needinfo?(kyee)
Done.
Group: qualcomm-confidential
(Assignee)

Comment 16

4 years ago
Merged on master: https://github.com/mozilla-b2g/gaia/commit/f9b2ce32876c8983480e3993ba649e742dcfc6b7
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(kaze)
Resolution: --- → FIXED
I was not able to uplift this bug to v1.3.  If this bug has dependencies which are not marked in this bug, please comment on this bug.  If this bug depends on patches that aren't approved for v1.3, we need to re-evaluate the approval.  Otherwise, if this is just a merge conflict, you might be able to resolve it with:

  git checkout v1.3
  git cherry-pick -x -m1 f9b2ce32876c8983480e3993ba649e742dcfc6b7
  <RESOLVE MERGE CONFLICTS>
  git commit
Flags: needinfo?(kaze)
status-b2g-v1.3: affected → fixed
You need to log in before you can comment on or make changes to this bug.