User is not automatically prompted to install the app they just bought

RESOLVED DUPLICATE of bug 920822

Status

Marketplace
Payments/Refunds
P2
normal
RESOLVED DUPLICATE of bug 920822
5 years ago
5 years ago

People

(Reporter: krupa, Unassigned)

Tracking

All
Android
Points:
---

Details

(Reporter)

Description

5 years ago
Samsung tablet/ Android 4.0.4

steps to reproduce:
1. Load marketplace.allizom.org on your latest Firefox Nightly
2. Start the purchase of a paid app
3. Log in using Persona
4. Enter PIN
5. Confirm MT auth using your phone number
6. Enter Credit card info
7. Confirm purchase

expected behavior:
After purchase the 'Payment Complete!' screen closes and the user is prompted to install the app they just bought

observed behavior:
After purchase the 'Payment Complete!' screen never closes. If the user closes it to return to the app details page, user is shown the 'Payment Cancelled' error message after a successful purchase.

I didn't see anything suspicious in the logcat.

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Priority: -- → P2
Resolution: --- → DUPLICATE
Duplicate of bug: 920822
You need to log in before you can comment on or make changes to this bug.